hdu 2647 拓扑排序

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4456    Accepted Submission(s): 1357

Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
 
Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
 
Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
 
Sample Input
  
  
2 1 1 2 2 2 1 2 2 1
 
Sample Output
  
  
1777 -1
题意:老板给员工发奖金,每个员工对自己的奖金都有 要求。他们的要求类似这样:A的奖金必须多余B。每个员工基础奖金888¥。 问:是否能满足所有员工?如果满足所有员工的要求,所发的总奖金最少是多少。
拓扑排序 反向储存边 判断是否有环 
#include<stdio.h>
#include<string.h>
int mp[10005][100],into[10005],list[10005],cant[10005];
int flag[10005];
int main()
{
    int n,m,x,y;
    while (scanf("%d%d",&n,&m)!=EOF)
    {
        int num=0;
        memset(mp,0,sizeof(mp));
        memset(into,0,sizeof(into));
        memset(flag,-1,sizeof(flag));
        memset(list,0,sizeof(list));
        for (int i=0; i<m; i++)
        {
            scanf("%d%d",&x,&y);
            mp[y][++mp[y][0]]=x;
            into[x]++;
        }
        int i=0;
        bool flaag=true;
        while (flaag)
        {
            flaag=false;
            int fabs=0;
            memset(cant,0,sizeof(cant));
            for (int j=1; j<=n; j++)
                if (into[j]==0&&flag[j]==-1)
                {
                    cant[fabs++]=j;
                    num++;
                    flag[j]=i;
                    flaag=true;
                }
            for (int j=0; j<fabs; j++)
            {
                for (int k=1; k<=mp[cant[j]][0]; k++)
                    into[mp[cant[j]][k]]--;
            }
            i++;
        }
        if (num!=n)
            puts("-1");
        else
        {
            int sum=0;
            sum=n*888;
            for (int i=1; i<=n; i++)
                sum+=flag[i];
            printf("%d\n",sum);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值