ZOJ Conquer a New Region(并查集)


The wheel of the history rolling forward, our king conquered a new region in a distant continent.

There are N towns (numbered from 1 to N) in this region connected by several roads. It's confirmed that there is exact one route between any two towns. Traffic is important while controlled colonies are far away from the local country. We define the capacity C(i, j) of a road indicating it is allowed to transport at most C(i, j) goods between town i and town j if there is a road between them. And for a route between i and j, we define a value S(i, j) indicating the maximum traffic capacity between i and j which is equal to the minimum capacity of the roads on the route.

Our king wants to select a center town to restore his war-resources in which the total traffic capacities from the center to the other N - 1 towns is maximized. Now, you, the best programmer in the kingdom, should help our king to select this center.

Input:

There are multiple test cases.

The first line of each case contains an integer N. (1 ≤ N ≤ 200,000)

The next N - 1 lines each contains three integers a, b, c indicating there is a road between town a and town b whose capacity is c. (1 ≤ a, b ≤ N, 1 ≤ c ≤ 100,000)

Output:
For each test case, output an integer indicating the total traffic capacity of the chosen center town.

Sample Input:

4
1 2 2
2 4 1
2 3 1
4
1 2 1
2 4 1
2 3 1

Sample Output:

4

3

解题思路:

贪心 + 并查集, 从大到小处理边,保证当前的边是已经处理过的边中权值最小的一个,然后判断是加到起点还是终点。

#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cmath>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <algorithm>
#define LL long long
using namespace std;
const int MAXN = 200000 + 10;
int F[MAXN];
struct Edge
{
    int u, v;
    int c;
    bool operator < (const Edge& rhs)const
    {
        return c > rhs.c;
    }
} edge[MAXN];
struct Node
{
    int num;
    long long sum;
} P[MAXN];
int Find(int x)
{
    return F[x] == -1 ? x : F[x] = Find(F[x]);
}
int main()
{
    int N;
    while(scanf("%d", &N)!=EOF)
    {
        //int u, v, c;
        for(int i=1; i<N; i++)
            scanf("%d%d%d", &edge[i].u, &edge[i].v, &edge[i].c);
        for(int i=1; i<=N; i++)
        {
            F[i] = -1;
            P[i].num = 1;
            P[i].sum = 0;
        }
        sort(edge + 1, edge + N);
        //for(int i=1;i<N;i++)
        //  cout << edge[i].u << ' ' << edge[i].v << ' ' <<edge[i].c << endl;
        for(int i=1; i<N; i++)
        {
            int fx = Find(edge[i].u);
            int fy = Find(edge[i].v);
            if(P[fx].sum + (long long )P[fy].num * edge[i].c < P[fy].sum + (long long )P[fx].num * edge[i].c)
            {
                F[fx] = fy;
                P[fy].num += P[fx].num;
                P[fy].sum += (long long)P[fx].num * edge[i].c;
            }
            else
            {
                F[fy] = fx;
                P[fx].num += P[fy].num;
                P[fx].sum += (long long )P[fy].num * edge[i].c;
            }
        }
        long long ans = P[Find(1)].sum;
        printf("%lld\n", ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值