hdu 4424 Conquer a New Region 并查集+思维

http://acm.hdu.edu.cn/showproblem.php?pid=4424

Conquer a New Region

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1565    Accepted Submission(s): 516


Problem Description
The wheel of the history rolling forward, our king conquered a new region in a distant continent.
There are N towns (numbered from 1 to N) in this region connected by several roads. It's confirmed that there is exact one route between any two towns. Traffic is important while controlled colonies are far away from the local country. We define the capacity C(i, j) of a road indicating it is allowed to transport at most C(i, j) goods between town i and town j if there is a road between them. And for a route between i and j, we define a value S(i, j) indicating the maximum traffic capacity between i and j which is equal to the minimum capacity of the roads on the route. 
Our king wants to select a center town to restore his war-resources in which the total traffic capacities from the center to the other N - 1 towns is maximized. Now, you, the best programmer in the kingdom, should help our king to select this center.
 

Input
There are multiple test cases.
The first line of each case contains an integer N. (1 <= N <= 200,000)
The next N - 1 lines each contains three integers a, b, c indicating there is a road between town a and town b whose capacity is c. (1 <= a, b <= N, 1 <= c <= 100,000)
 

Output
For each test case, output an integer indicating the total traffic capacity of the chosen center town.
 

Sample Input
  
  
4 1 2 2 2 4 1 2 3 1 4 1 2 1 2 4 1 2 3 1
 

Sample Output
  
  
4 3
 


题意: 树形结构,选出一个点,这个点到任何一个其他点 路径上 的最小边权  最大的 和是多少。

做法:根据边权排序, 每次合并最大边权的两个点。  两个点各在一个集合,dian表示这个集合有多少点,dis表示这个集合内部 某个点 到其他所有点的 路径上的 最小边权 的最大和。u_是u 所在集合的祖先,如果以u_为合并后的祖先,那么把dian[u_]更新为两个集合的点和,当前枚举的边肯定比之前的边要小,所以 dis[u_] = dian[v_]*w+dis[u_]。把 以v_为祖先 所得的 答案作比较, 取答案较大的那个 点做为祖先。不断合并,最后形成的集合的 dis 就是答案了。


#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <string>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <map>
#include <cmath>
#include <vector>
#include <sstream>
#include <set>
using namespace std;
typedef long long LL;


/*
1
4 10
110 5 9
30 2 1
80 4 8
50 3 2
*/
 
#define M 310000
struct Edge{
	LL u, v, w;
}edge[M]; 

LL cmp(Edge a,Edge b)
{
	return a.w>b.w;
}

LL f[M];

LL find(LL tt)
{
	if(f[tt]==-1)
		return tt;
	else
		return f[tt]=find(f[tt]);
}

LL dis[M];
LL dian[M];

int main()
{
	LL n;
	while(scanf("%I64d",&n)!=EOF)
	{ 
		for(LL i=0;i<n-1;i++)
		{
			LL u,v,w;
			scanf("%I64d%I64d%I64d",&u,&v,&w);
			edge[i].u=u;
			edge[i].v=v;
			edge[i].w=w; 
		}
		memset(f,-1,sizeof f);
		sort(edge,edge+n-1,cmp);
		
		memset(dis,0,sizeof dis);
		for(LL i=0;i<=n+10;i++)
			dian[i]=1;
		for(LL i=0;i<n-1;i++)
		{
			LL u=edge[i].u;
			LL v=edge[i].v;
			LL w=edge[i].w;

			LL u_=find(u);
			LL v_=find(v);

			LL ans1= dian[u_]*w+dis[v_];

			LL ans2= dian[v_]*w+dis[u_];

			if(ans1>ans2)
			{
				dian[v_]=dian[v_]+dian[u_];
				dis[v_]=ans1;
				f[u_]=v_;
			}
			else
			{
				dian[u_]=dian[v_]+dian[u_];

				dis[u_]=ans2;

				f[v_]=u_;
			}
		}

		printf("%I64d\n",dis[find(1)]);
	}
	return 0;
}

/*
3
0 1 1
1 0 0
1 0 0
*/

 




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值