zoj3659 Conquer a New Region (并查集)

Conquer a New Region

Time Limit: 5 Seconds       Memory Limit: 32768 KB

The wheel of the history rolling forward, our king conquered a new region in a distant continent.

There are N towns (numbered from 1 to N) in this region connected by several roads. It's confirmed that there is exact one route between any two towns. Traffic is important while controlled colonies are far away from the local country. We define the capacity C(i, j) of a road indicating it is allowed to transport at most C(i, j) goods between town i and town j if there is a road between them. And for a route between i and j, we define a value S(i, j) indicating the maximum traffic capacity between i and j which is equal to the minimum capacity of the roads on the route.

Our king wants to select a center town to restore his war-resources in which the total traffic capacities from the center to the other N - 1 towns is maximized. Now, you, the best programmer in the kingdom, should help our king to select this center.

Input

There are multiple test cases.

The first line of each case contains an integer N. (1 ≤ N ≤ 200,000)

The next N - 1 lines each contains three integers a, b, c indicating there is a road between town a and town b whose capacity is c. (1 ≤ a, b ≤ N, 1 ≤ c ≤ 100,000)

Output

For each test case, output an integer indicating the total traffic capacity of the chosen center town.

Sample Input
4
1 2 2
2 4 1
2 3 1
4
1 2 1
2 4 1
2 3 1
Sample Output
4
3
题目意思是让你找一个中心点,让它的 traffic capacity最大
并查集,先排序然后从大到小加入树,
#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
struct ege{
	int a,b,c;
}s[200100];
int par[200100],num[200100];
long long cost[200100];

int find(int i)
{
	if(par[i]==i)
		return i;
	return par[i]=find(par[i]);
}

bool cmp(ege a,ege b)
{
	return a.c>b.c;//升序排列
}
int main()
{
	int i,j,k,n,m,ta,tb;
	long long tma,tmb;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n-1;i++)
			scanf("%d%d%d",&s[i].a,&s[i].b,&s[i].c);
		sort(s,s+n-1,cmp);
		for(i=0;i<=n;i++)
		{
			par[i]=i;
			num[i]=1;
			cost[i]=0;
		}
		for(i=0;i<n-1;i++)
		{
			ta=find(s[i].a);//a的根节点
			tb=find(s[i].b);//b的根节点
			tma=(long long)s[i].c*num[tb]+cost[ta];//分两边算,选一个最大的,另外注意这个long long必须加上,不然就WA,我想可能是因为int和long long混合运算的问题
			tmb=(long long)s[i].c*num[ta]+cost[tb];
			if(tma>tmb)//a这边大
			{
				cost[ta]=tma;//ta这点的价值
				par[tb]=ta;//b加入a
				num[ta]+=num[tb];//ta的子数目加上b的子节点数目
			}
			else
			{
				cost[tb]=tmb;
				par[ta]=tb;
				num[tb]+=num[ta];
			}
		}
		printf("%lld\n",cost[find(1)]);//找到最终的根节点,它的C肯定是最大的
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值