HDU 4734 F(X) 数位DP

Problem Description:

For a decimal number x with n digits (AnAn-1An-2 ... A2A1), we define its weight as F(x) = An * 2n-1 + An-1 * 2n-2 + ... + A2 * 2 + A1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).


Input:

The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 109)


Output:

For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.


Sample Input:

3

0 100

1 10

5 100


Sample Output:

  
  
Case #1: 1 Case #2: 2 Case #3: 13

#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#define ll long long 
using namespace std;
const int MAXN = 200000 + 10;;
int bit[20];
int A, B;
int F(int x)
{
	int ans = 0;
	int m = 0;
	while (x)
	{
		ans += (x % 10) * (1 << m);
		m++;
		x /= 10;
	}
	return ans;
}
int dp[20][MAXN];
int dfs(int pos, int pre, bool flag)
{
	if (pos == -1) return (pre >= 0);
	if (pre < 0) return 0;
	if (!flag && dp[pos][pre] != -1)
		return dp[pos][pre];
	int end = flag ? bit[pos] : 9;
	int ans = 0;
	for (int i = 0; i <= end; i++)
		ans += dfs(pos - 1, pre - i * (1 << pos), flag && i == end);
	if (!flag) return dp[pos][pre] = ans;
	return ans;
}
int solve(int x)
{
	int m = 0;
	while (x)
	{
		bit[m++] = x % 10;
		x /= 10;
	}
	int res = dfs(m - 1, F(A), 1);
	return res;
}
int main()
{
	int T, kcase = 1;
	cin >> T;
	memset(dp, -1, sizeof(dp));
	while (T--)
	{
		cin >> A >> B;
		cout << "Case #" << kcase++ << ": " << solve(B) << endl;
	}
	//system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值