F(x)

F(x)

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5055    Accepted Submission(s): 1880


Problem Description
For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
 

Output
For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.
 

Sample Input
  
  
3 0 100 1 10 5 100
 

Sample Output
  
  
Case #1: 1 Case #2: 2 Case #3: 13

题意:找出i在0到b之间的f(i)小于等于f(a)的数的个数。

思路:数位dp。主要在于状态转移不好想。dp[i][j]表示i位数比j小的数的个数。用递归完成的话就只需要思考边界和状态转移。

边界:

dp[i][j]如果j小于0,显然是dp[i][j]=0的,如果i==0,说明就是0,显然任何数都比0大,所以dp[i][j]对于j>=0的时候dp[i][j]=1,否则dp[i][j]=0

状态转移:

dp[i][j]+=dp[i-1][j-k*(1<<(i))];j的初始值是sum

完成上述两步推导就能开始写这题了。

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const int MOD = 1000000007;
const int maxn = 200010;
int  num[30],len;
LL  dp[30][10000];
int a[50];
int sum;
LL dfs(int pos,LL zhi,int last)//zhi是差值
{
    if(pos<0) return zhi>=0;//当差值大于等于0时,说明这个数符合要求,+1,否则+0
    if(zhi<0) return 0;//当差值小于0时就+0,
    if(!last&&dp[pos][zhi]!=-1)
    {
        return dp[pos][zhi];
    }
    int len=last?num[pos]:9;
    LL res = 0;
    for(int i=0; i<=len; i++)
    {
        res += dfs(pos-1,(zhi-i*(1<<pos)),last&&(i==len));
    }
    if(!last)dp[pos][zhi]= res;
    return res;
}
LL solve(LL n)
{
    len = 0;
    while(n)
    {
        num[len++] = n%10;
        n /= 10;
    }
    return dfs(len-1,sum,1);//用sum一直去减
}
int main()
{
    memset(dp,-1,sizeof(dp));
    int _;
    scanf("%d",&_);
    int g=0;
    while(_--)
    {
        LL n,m;
        ++g;
        scanf("%I64d%I64d",&m,&n);
        sum=0;
        int l=0;
        while(m)//算sum
        {
            sum+=(m%10)*(1<<l);
            l++;
            m=m/10;
        }
        printf("Case #%d: ",g);
        if(sum==0)
            printf("%d\n",1);
        else
        printf("%I64d\n",solve(n));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值