Hdu-4734 F(x)(数位DP)

185 篇文章 0 订阅
96 篇文章 0 订阅
Problem Description
For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
 

Output
For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.
 

Sample Input
  
  
3 0 100 1 10 5 100
 

Sample Output
  
  
Case #1: 1 Case #2: 2 Case #3: 13



分析:这里有一个小优化技巧,dp[i][j]表示目前第i位,最多再凑j的方案数,这样一来dp数组的值就和n无关了。


#include<iostream>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<cstdio>
#include<set>
#include<map>
#include<vector>
#include<ctime>  
#include<cstring>
#include<stack>
#include<cmath>
#include<queue>
#define INF 0x3f3f3f3f
#define eps 1e-9
#define MAXN 100000
using namespace std;
int T,n,m,dp[12][10000],a[12];
int dfs(int pos,int sta,int limit)
{
	if(pos == -1) return sta <= n;
	if(sta > n) return 0;
	if(!limit && dp[pos][n-sta] >= 0) return dp[pos][n-sta];
	int up = limit ? a[pos] : 9;
	int ans = 0;
	for(int i = 0;i <= up;i++)
	{
		ans += dfs(pos-1,sta + i*(1<<pos),limit && i == up);
	}
	if(!limit) dp[pos][n-sta] = ans;
	return ans;
}
int got(int x)
{
	int ans = 0,pos = 0;
	while(x)
	{
		ans += (x % 10)*(1<<pos);
		x /= 10;
		pos++;
	}
	return ans;
}
int solve(int x)
{
	int pos = 0;
	while(x)
	{
		a[pos++] = x % 10;
		x /= 10;
	}
	return dfs(pos-1,0,1);
}
int main()
{
	memset(dp,-1,sizeof(dp));
	scanf("%d",&T);
	for(int t = 1;t <= T;t++)
	{
		scanf("%d%d",&n,&m);
		n = got(n);
		printf("Case #%d: %d\n",t,solve(m));
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值