HDU 5289 Assignment(2015 多校第一场二分 + RMQ)

5 篇文章 0 订阅
3 篇文章 0 订阅

Assignment

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 627    Accepted Submission(s): 318


Problem Description
Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group, the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.
 

Input
In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.
 

Output
For each test,output the number of groups.
 

Sample Input
  
  
2 4 2 3 1 2 4 10 5 0 3 4 5 2 1 6 7 8 9
 

Sample Output
  
  
5 28
Hint
First Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3]
 

Author
FZUACM
 

Source


解题思路:
枚举左端点,二分查找右端点,用RMQ维护区间最大值和最小值

#include <iostream>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <cstdio>
#include <queue>
#include <vector>
#include <stack>
#define LL long long
using namespace std;
const int MAXN = 100000 + 10;
int A[MAXN];
int dp1[MAXN][20], dp[MAXN][20];
int N, M;
void RMQ_init_Min()
{
    for(int i=0;i<N;i++) dp1[i][0] = A[i];
    for(int j=1;(1<<j) <= N;j++)
    {
        for(int i=0;i+(1<<j) - 1 < N;i++)
        {
            dp1[i][j] = min(dp1[i][j-1], dp1[i + (1<<(j-1))][j-1]);
        }
    }
}
int RMQ_Min(int L, int R)
{
    int k = 0;
    while(1<<(k+1) <= R - L + 1) k++;
    return min(dp1[L][k], dp1[R-(1<<k)+1][k]);
}
void RMQ_init_Max()
{
    for(int i=0;i<N;i++) dp[i][0] = A[i];
    for(int j=1;(1<<j) <= N;j++)
    {
        for(int i=0;i+(1<<j) - 1 < N;i++)
        {
            dp[i][j] = max(dp[i][j-1], dp[i + (1<<(j-1))][j-1]);
        }
    }
}
int RMQ_Max(int L, int R)
{
    int k = 0;
    while(1<<(k+1) <= R - L + 1) k++;
    return max(dp[L][k], dp[R-(1<<k)+1][k]);
}
int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d%d", &N, &M);
        for(int i=0;i<N;i++) scanf("%d", &A[i]);
        RMQ_init_Min();
        RMQ_init_Max();
        long long ans = 0;
        for(int i=0;i<N;i++)
        {
            int l = i, r = N-1;
            while(l <= r)
            {
                int mid = (l + r) >> 1;
                int low = RMQ_Min(i, mid);
                int high = RMQ_Max(i ,mid);
                //cout << l << ' ' << r << ' ' << high << ' ' <<low << endl;
                if(high - low < M) l = mid + 1;
                else r = mid - 1;
            }
            //cout << l << endl;
            ans += (l - i);
        }
        printf("%I64d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值