hdu 1867 A + B for you again

A + B for you again

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4214    Accepted Submission(s): 1077


Problem Description
Generally speaking, there are a lot of problems about strings processing. Now you encounter another such problem. If you get two strings, such as “asdf” and “sdfg”, the result of the addition between them is “asdfg”, for “sdf” is the tail substring of “asdf” and the head substring of the “sdfg” . However, the result comes as “asdfghjk”, when you have to add “asdf” and “ghjk” and guarantee the shortest string first, then the minimum lexicographic second, the same rules for other additions.
 

Input
For each case, there are two strings (the chars selected just form ‘a’ to ‘z’) for you, and each length of theirs won’t exceed 10^5 and won’t be empty.
 

Output
Print the ultimate string by the book.
 

Sample Input
  
  
asdf sdfg asdf ghjk
 

Sample Output
  
  
asdfg asdfghjk
 

Author
Wang Ye
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1711  1866  3336  1277  1358 
 
【题意】kmp
【思路】kmp匹配~~
【代码】
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int const MAXN=100000+10;

char T[MAXN],S[MAXN];
int  P[MAXN];
void KMP_solveS(const char *S,int *P)
{
    P[0]=-1;
    int j=-1;
    int lenS=strlen(S);
    for(int i=1;i<lenS;i++)
    {
        while(j>=0&&S[j+1]!=S[i])
            j=P[j];
        if(S[j+1]==S[i])
            j=j+1;
        P[i]=j;
    }
}

int KMP(const char *T,const char *S)
{
    int lenT=strlen(T);
    int lenS=strlen(S);
    KMP_solveS(S,P);
    int j=-1;
    for(int i=0;i<lenT;i++)
    {
        while(j>=0&&S[j+1]!=T[i])
            j=P[j];
        if(S[j+1]==T[i])
            j=j+1;
        if(j==lenS-1)
        {
            if(i==lenT-1)
                break;
            j=P[j];
        }
    }
    return j;
}

int main()
{
    while(scanf("%s%s",T,S)!=EOF)
    {
        int l1=KMP(T,S);
        int l2=KMP(S,T);
        int len1=strlen(T);
        int len2=strlen(S);
        if(l2<l1||((l1==l2)&&strcmp(T,S)<=0))
            printf("%s%s\n",T,S+l1+1);
        else
            printf("%s%s\n",S,T+l2+1);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值