HDU 1867 A + B for you again 【KMP】

A + B for you again

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8399    Accepted Submission(s): 2098


Problem Description
Generally speaking, there are a lot of problems about strings processing. Now you encounter another such problem. If you get two strings, such as “asdf” and “sdfg”, the result of the addition between them is “asdfg”, for “sdf” is the tail substring of “asdf” and the head substring of the “sdfg” . However, the result comes as “asdfghjk”, when you have to add “asdf” and “ghjk” and guarantee the shortest string first, then the minimum lexicographic second, the same rules for other additions.
 

Input
For each case, there are two strings (the chars selected just form ‘a’ to ‘z’) for you, and each length of theirs won’t exceed 10^5 and won’t be empty.
 

Output
Print the ultimate string by the book.
 

Sample Input
  
  
asdf sdfg asdf ghjk
 

Sample Output
  
  
asdfg asdfghjk
#include<bits/stdc++.h>
using namespace std;
#define MAX 100005
int _next[MAX];
char s[MAX], t[MAX];
void getnext(char *a)
{
    int i = 0, j = -1, len = strlen(a);
    _next[0] = -1;
    while(i < len)
        if(j == -1 || a[i] == a[j])
            _next[++i] = ++j;
        else
            j = _next[j];
}
int kmp(char *a, char *b)
{
    int i = 0, j = 0;
    int len1 = strlen(a), len2 = strlen(b);
    getnext(b);
    while(i < len1 && j < len2)
    {
        if(j == -1 || a[i] == b[j])
        {
            i++;
            j++;
        }
        else
            j = _next[j];
    }
    if(i == len1)
        return j;
    return 0;
}
int main()
{
    ios::sync_with_stdio(false);
    while(cin >> s >> t)
    {
        int x = kmp(s, t), y = kmp(t, s);
        if(x == y)
            if(strcmp(s, t) > 0)
                cout << t << s + x << endl;
            else
                cout << s << t + x << endl;
        else if(x > y)
            cout << s << t + x << endl;
        else
            cout << t << s + y << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值