HDU 2224 The shortest path(双调欧几里得旅行商问题)

The shortest path

Description

There are n points on the plane, Pi(xi, yi)(1 <= i <= n), and xi < xj (i<j). You begin at P1 and visit all points then back to P1. But there is a constraint:
Before you reach the rightmost point Pn, you can only visit the points those have the bigger x-coordinate value. For example, you are at Pi now, then you can only visit Pj(j > i). When you reach Pn, the rule is changed, from now on you can only visit the points those have the smaller x-coordinate value than the point you are in now, for example, you are at Pi now, then you can only visit Pj(j < i). And in the end you back to P1 and the tour is over.
You should visit all points in this tour and you can visit every point only once.
 

Input

The input consists of multiple test cases. Each case begins with a line containing a positive integer n(2 <= n <= 200), means the number of points. Then following n lines each containing two positive integers Pi(xi, yi), indicating the coordinate of the i-th point in the plane.
 

Output

For each test case, output one line containing the shortest path to visit all the points with the rule mentioned above.The answer should accurate up to 2 decimal places.
 

Sample Input

    
    
3 1 1 2 3 3 1
 

Sample Output

6.47


双调欧几里得旅行商问题


#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
using namespace std;

const int INF = 1<<29;
const int MAXN = 1100;
const double PI = acos(-1.0);
const double e = 2.718281828459;
const double eps = 1e-8;
struct node
{
    double x;
    double y;
}a[MAXN];
double dp[MAXN][MAXN];

int cmp(node a, node b)
{
    return a.x < b.x;
}

double dist(int i, int j)
{
    return sqrt((a[i].x-a[j].x)*(a[i].x-a[j].x)+(a[i].y-a[j].y)*(a[i].y-a[j].y));
}

int main()
{
    //freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
    int n;
    while(cin>>n)
    {
        for(int i = 1; i <= n; i++)
        {
            scanf("%lf %lf", &a[i].x, &a[i].y);
        }
        sort(a+1, a+1+n, cmp);
        dp[2][1] = dist(1, 2);
        for(int i = 3; i <= n; i++)
        {
            dp[i][i-1] = INF*1.0;
            for(int j = 1; j < i-1; j++)
            {
                dp[i][i-1] = min(dp[i][i-1], dp[i-1][j]+dist(i, j));
                dp[i][j] = dp[i-1][j]+dist(i-1, i);
            }
        }
        double ans = INF*1.0;
        for(int i = 1; i < n; i++)
        {
            ans = min(ans, dp[n][i]+dist(n, i));
        }
        printf("%.2f\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值