CCNA实验二 (RIP协议)

实验目的

在这里插入图片描述

使用RIP协议连通路由

使用工具

EVE-NG

SecureCRT

命令行

R1命令如下:

Router>en
Router#conf
Router#configure t
Router#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#inter
Router(config)#interface loop 
Router(config)#interface loopback 0
Router(config-if)#ip address 1.1.1.1 255.255.255.0
Router(config-if)#exit
Router(config)#interface ethernet 0/0
Router(config-if)#ip address 12.1.1.1 255.255.255.0
Router(config-if)#no shu
Router(config-if)#exit
Router(config)#
*Jul 10 23:43:34.111: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Jul 10 23:43:35.120: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up 
Router(config)#interface ethernet 0/1
Router(config-if)#ip address 13.1.1.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#
*Jul 10 23:44:10.044: %LINK-3-UPDOWN: Interface Ethernet0/1, changed state to up
*Jul 10 23:44:11.050: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1, changed state to up
Router(config)#router Rip 
Router(config-router)#version 2
Router(config-router)#no auto-summary 
Router(config-router)#do show ip int b
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                12.1.1.1        YES manual up                    up      
Ethernet0/1                13.1.1.1        YES manual up                    up      
Ethernet0/2                unassigned      YES unset  administratively down down    
Ethernet0/3                unassigned      YES unset  administratively down down    
Serial1/0                  unassigned      YES unset  administratively down down    
Serial1/1                  unassigned      YES unset  administratively down down    
Serial1/2                  unassigned      YES unset  administratively down down    
Serial1/3                  unassigned      YES unset  administratively down down    
Loopback0                  1.1.1.1         YES manual up                    up      
Router(config-router)#network 12.0.0.0
Router(config-router)#network 13.0.0.0
Router(config-router)#network 1.0.0.0
Router(config-router)#end
Router#
*Jul 10 23:45:51.719: %SYS-5-CONFIG_I: Configured from console by console
Router#show ip protocols 
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 18 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Ethernet0/0           2     2                                    
    Ethernet0/1           2     2                                    
    Loopback0             2     2                                    
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    1.0.0.0
    12.0.0.0
    13.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    13.1.1.3             120      00:00:23
    12.1.1.2             120      00:00:05
  Distance: (default is 120)
          
Router#
Router#

R2命令如下:

Router>en
Router#configure t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int ethernet 0/0
Router(config-if)#ip address 12.1.1.2 255.255.255.0
Router(config-if)#no shu
Router(config-if)#exit
Router(config)#
*Jul 10 23:46:42.750: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Jul 10 23:46:43.755: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up
Router(config)#interface loopback 0
Router(config-if)#  
*Jul 10 23:46:50.640: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
Router(config-if)#ip address 2.2.2.2 255.255.255.0
Router(config-if)#exit
% Incomplete command.

Router(config)#do show ip int b
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                12.1.1.2        YES manual up                    up      
Ethernet0/1                unassigned      YES unset  administratively down down    
Ethernet0/2                unassigned      YES unset  administratively down down    
Ethernet0/3                unassigned      YES unset  administratively down down    
Loopback0                  2.2.2.2         YES manual up                    up      
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#no auto-summary 
Router(config-router)#network
Router(config-router)#network 12.0.0.0
Router(config-router)#network
Router(config-router)#network 2.0.0.0  
Router(config-router)#end
Router#
*Jul 10 23:47:49.943: %SYS-5-CONFIG_I: Configured from console by console

Router#show ip protocols 
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 20 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Ethernet0/0           2     2                                    
    Loopback0             2     2                                    
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    2.0.0.0
    12.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    12.1.1.1             120      00:00:09
  Distance: (default is 120)
          
Router#

R3 命令如下:(最后尝试ping了一下)

Router>en
Router#config
Router#configure t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface loopback 0
*Jul 10 23:48:06.311: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
Router(config-if)#ip address 3.3.3.3 255.255.255.0
Router(config-if)#exit
Router(config)#int ethernet 0/0
Router(config-if)#ip address 13.1.1.3 255.255.255.0
Router(config-if)#no shu
Router(config-if)#
*Jul 10 23:48:40.590: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Jul 10 23:48:41.595: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up
Router(config-if)#do show ip int b
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                13.1.1.3        YES manual up                    up      
Ethernet0/1                unassigned      YES unset  administratively down down    
Ethernet0/2                unassigned      YES unset  administratively down down    
Ethernet0/3                unassigned      YES unset  administratively down down    
Loopback0                  3.3.3.3         YES manual up                    up      
Router(config-if)#exit    
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#no auto-summary 
Router(config-router)#network 13.0.0.0
Router(config-router)#network 3.0.0.0
Router(config-router)#end
Router#sho
*Jul 10 23:49:24.199: %SYS-5-CONFIG_I: Configured from console by console
Router#show ip r
Router#show ip ro 
Router#show ip route 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/24 is subnetted, 1 subnets
R        1.1.1.0 [120/1] via 13.1.1.1, 00:00:28, Ethernet0/0
      2.0.0.0/24 is subnetted, 1 subnets
R        2.2.2.0 [120/2] via 13.1.1.1, 00:00:28, Ethernet0/0
      3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        3.3.3.0/24 is directly connected, Loopback0
L        3.3.3.3/32 is directly connected, Loopback0
      12.0.0.0/24 is subnetted, 1 subnets
R        12.1.1.0 [120/1] via 13.1.1.1, 00:00:28, Ethernet0/0
      13.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        13.1.1.0/24 is directly connected, Ethernet0/0
L        13.1.1.3/32 is directly connected, Ethernet0/0
Router#show ip protocols 
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 5 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Ethernet0/0           2     2                                    
    Loopback0             2     2                                    
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    3.0.0.0
    13.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    13.1.1.1             120      00:00:19
  Distance: (default is 120)
          

Router#ping 12.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Router#
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值