HDU-2277 Change the ball

Change the ball

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 482    Accepted Submission(s): 168


Problem Description
Garfield has three piles of balls, each pile has unique color of following: yellow, blue, and red. Now we also know Garfield has Y yellow balls, B blue balls, and R red balls. But Garfield just wants to change all the balls to one color. When he puts two balls of different color togather, the balls then change their colors automatically into the rest color. For instance, when Garfield puts a red one and a yellow one togather, the two balls immediately owns blue color, the same to other situations. But the rule doesn’t work when the two balls have the same color.
  Garfield is not able to estimate the minimal steps to achieve the aim. Can you tell him?

 

Input
For each line, there are three intergers Y, B, R(1<=Y,B,R<=1000),indicate the number refered above.
 

Output
For each case, tell Garfield the minimal steps to complete the assignment. If not, output the symbol “):”.
 

Sample Input
      
      
1 2 3 1 2 2
 

Sample Output
      
      
): 2
 
题目大意:两种不同颜色的球可以变成另外一种颜色的球,两种不同颜色的球不能变成其他两种颜色的球 ,将三种不同颜色的球变为一种颜色,最少所需要的次数;
解题思路:首先根据题意,我们可以发现,将两种不同颜色的球变成其他颜色的球,例如(Y,B)->R;
我们可以发现 Y=Y+1;B=B+1;R=R+2;(Y-R)%3==(B-R)%3==0;
也就是说,任意两个球之间只要是3的倍数就一定能变成;将这两种球完全变没有,所得的变化次数一定是MAX(a,b);
最后求最小值就行了;

# include <iostream>
# define INF 1<<30
# define MAX(a,b) a>b?a:b
# define MIN(a,b) a<b?a:b
# include <math.h>
using namespace std;
int f(int a,int b,int c)
{
    int mark=0;
    int sum1,sum2,sum3;
        sum1=sum2=sum3=INF;
    if((a-b)%3==0)
    {
        mark=1;
        sum1=MAX(a,b);
    }
    if((a-c)%3==0)
    {
        mark=1;
        sum2=MAX(a,c);
    }
    if((b-c)%3==0)
    {
        mark=1;
        sum3=MAX(b,c);
    }
    if(mark==0)
        return 0;
    else
        return MIN(MIN(sum1,sum2),sum3);
}
int main()
{
    int y,b,r,sum;
    while(cin>>y>>b>>r)
    {
        sum=f(y,b,r);
        if(sum==0)
            cout<<"):"<<endl;
        else    
            cout<<sum<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值