Sliding Window(线段树)

2 篇文章 0 订阅
Sliding Window
Time Limit: 12000MS  Memory Limit: 65536K
Total Submissions: 32563  Accepted: 9681
Case Time Limit: 5000MS

Description

An array of size  n ≤ 10 6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and  k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

 

    题意:

    有N(1到10^6)个数,每K(1到N)个数一组。求出每组的最小值和最大值,最小值和最大值分别一行输出。

 

    思路:

    线段树基础题。线段树维护最大值最小值。

 

    AC:

#include<stdio.h>
#define MAX 1000005
typedef struct
{
	int l;
	int r;
	int min;
	int max;
}node;
node no[MAX*5];
int num[MAX];
int fma,fmi;

void build(int from,int to,int i)
{
	int mid=(from+to)/2;
	no[i].l=from;
	no[i].r=to;
	if(from==to)
	{
		no[i].max=num[from];
		no[i].min=num[from];
		return;
	}
	build(from,mid,2*i);
	build(mid+1,to,2*i+1);
	no[i].max=(no[2*i].max>no[2*i+1].max?no[2*i].max:no[2*i+1].max);
	no[i].min=(no[2*i].min<no[2*i+1].min?no[2*i].min:no[i*2+1].min);
}

void findmax(int from,int to,int i)
{
	int mid=(no[i].l+no[i].r)/2;
	if(from==no[i].l&&to==no[i].r)
	{
		fma=(fma>no[i].max?fma:no[i].max);
		return;
	}
	if(from>=mid+1) findmax(from,to,2*i+1);
	if(to<=mid)		findmax(from,to,2*i);
	if(from<=mid&&to>=mid+1)
	{
		findmax(from,mid,2*i);
		findmax(mid+1,to,2*i+1);
	}
}

void findmin(int from,int to,int i)
{
	int mid=(no[i].l+no[i].r)/2;
	if(from==no[i].l&&to==no[i].r)
	{
		fmi=(fmi>no[i].min?no[i].min:fmi);
		return;
	}
	if(from>=mid+1) findmin(from,to,2*i+1);
	if(to<=mid)	findmin(from,to,2*i);
	if(from<=mid&&to>=mid+1)
	{
		findmin(from,mid,2*i);
		findmin(mid+1,to,2*i+1);
	}
}

int main()
{
	int n,m;
	scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++)
			scanf("%d",&num[i]);
		build(1,n,1);
		for(int i=1;i<=n-m+1;i++)
		{
			fmi=num[i];
//WA了N遍,就是因为赋值这里
//一开始赋值fmi=MAX;
//因为fmin是int型的,存MAX不够存
			findmin(i,i+m-1,1);
			printf("%d",fmi);
			i==n-m+1?printf("\n"):printf(" ");
		}
		for(int i=1;i<=n-m+1;i++)
		{
			fma=num[i];
//同理,这里也不可以赋值为fma=-MAX
			findmax(i,i+m-1,1);
			printf("%d",fma);
			i==n-m+1?printf("\n"):printf(" ");
		}
	return 0;
}

 

    总结:

    1.细节的错误现在遇到得比较多,都是不容易发现的错误;

    2.不是多输入和输出格式的错误,赋值的时候要注意要在数据范围内赋值。

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值