Period(KMP)

Period
Time Limit: 3000MS  Memory Limit: 30000K
Total Submissions: 11807  Accepted: 5501

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

Source

    题意:

    多个case,输入0结束。每个case都有一个 N (2 <= N <= 1 000 000) ,代表有一个n长度的字符串,随后给出字符串。i 表示字符串的前缀长度,从2到N,求出每个前缀子串的最大重复周期 K(K > 1),按 i 的升序输出。

 

    思路:

    利用 KMP 的 next 值,与上一道题类似。要注意的是,判断整除并且周期要大于1才输出,并且外循环是从i = 2开始。字符串数组是从 0 开始的,所以故循环要循环到 n 长度为止。

 

    AC:

#include<stdio.h>
int n,next[1000005];
char str[1000005];

void get_next()
{
    int i = 0,j = -1;
    next[0] = -1;
    while(i < n)
    {
        if(j == -1 || str[i] == str[j]) next[++i] = ++j;
        else                            j = next[j];
    }
}

int main()
{
    int test = 0;
    while(scanf("%d",&n)!=EOF && n)
    {
        int per;
        test++;
        for(int i = 0;i < n;i++)
            scanf(" %c",&str[i]);
        get_next();
        per = n - next[n];
        printf("Test case #%d\n",test);
        for(int i = 2;i <= n;i++)   //循环到n
            if(!(i % (i - next[i])) && (i / (i - next[i]) != 1))
            printf("%d %d\n",i,i / (i - next[i]));
        printf("\n");
    }
    return 0;
}

 

    

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值