N - Period

题目描述:

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4
题意:求一串字符中的前缀中有多少最大周期数。
例如“aaa”中,前两个“aa”最小周期长度为“a”,所以周期长度为2,前三个“aaa”的最小周期也是“a”所以周期长度为3;
再如“aabaabaabaab”中前6个“aabaab”的最小周期长度为“aab”,所以周期为2。
其实也这样理解,从第二个字符开始(即下标依次为0-n),依次将第n个以前的字符看成一个字符串。并求这个字符串的最小循环节是否%长度==0。
例如:
aabaabaabaab中:
aa 是两个a组成的。
aabaab是两个aab组成的
aabaabaab是三个aab组成
aabaabaabaab是四个aab组成。
分析:本题无非也就是对next数组的应用。依次判断一下循环节%长度是否等于0就可以了。‘
见代码:

#include"stdio.h"
#include"string.h"
char text[1000001];
int next[1000001];
void Get_next(char text[],int next[])
{
    int i,j,len;
    next[0]=-1;
    i=0;
    j=-1;
    len=strlen(text);
    while(i<len)
    {
        if(j==-1||text[i]==text[j])
        {
            i++;
            j++;

            next[i]=j;
        }
        else
            j=next[j];
    }

}
int main()
{
    int N;

    int ans;
    int i,len,k=1;
    while(~scanf("%d",&N))
    {
        if(N==0)
            break;
        scanf("%s",text);
        printf("Test case #%d\n",k++);

        len=strlen(text);
        Get_next(text,next);
        for(i=2; i<=len; i++)
        {
            ans=i-next[i];
            if(i%ans==0&&i!=ans)
                printf("%d %d\n",i,i/ans);
        }
        printf("\n");

    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值