Walk(概率DP)

Walk

Time Limit: 30000/15000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 291    Accepted Submission(s): 200
Special Judge


Problem Description
I used to think I could be anything, but now I know that I couldn't do anything. So I started traveling.

The nation looks like a connected bidirectional graph, and I am randomly walking on it. It means when I am at node i, I will travel to an adjacent node with the same probability in the next step. I will pick up the start node randomly (each node in the graph has the same probability.), and travel for d steps, noting that I may go through some nodes multiple times.

If I miss some sights at a node, it will make me unhappy. So I wonder for each node, what is the probability that my path doesn't contain it.
 

 

Input
The first line contains an integer T, denoting the number of the test cases.

For each test case, the first line contains 3 integers n, m and d, denoting the number of vertices, the number of edges and the number of steps respectively. Then m lines follows, each containing two integers a and b, denoting there is an edge between node a and node b.

T<=20, n<=50, n-1<=m<=n*(n-1)/2, 1<=d<=10000. There is no self-loops or multiple edges in the graph, and the graph is connected. The nodes are indexed from 1.
 

 

Output
For each test cases, output n lines, the i-th line containing the desired probability for the i-th node.

Your answer will be accepted if its absolute error doesn't exceed 1e-5.
 

 

Sample Input
2
5 10 100
1 2
2 3
3 4
4 5
1 5
2 4
3 5
2 5
1 4
1 3
10 10 10
1 2
2 3
3 4
4 5
5 6
6 7
7 8
8 9
9 10
4 9
 

 

Sample Output

 

0.0000000000
0.0000000000
0.0000000000
0.0000000000
0.0000000000
0.6993317967
0.5864284952
0.4440860821
0.2275896991
0.4294074591
0.4851048742
0.4896018842
0.4525044250
0.3406567483
0.6421630037

     题意:

     给出 T 组case,后给出 N 个结点,M 条边,还有 D 步。任意选择一个起点开始,求出所有在 D 步内不经过结点 i 的概率。输出概率。

 

     思路:

     概率 DP。dp [ i ] [ k ] 表示在 k 步内不经过 i 点的概率,故更新的时候更新所有边中不存在 i 结点的边,最后概率即为 sum { dp [ j ] [ d ] ( 1 <= j <= n && j != i ) }。

 

     AC:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>

using namespace std;

const int VMAX = 55;
const int STEP = 10005;

vector<int> G[VMAX];
double dp[STEP][VMAX];

int main() {

    int t;
    scanf("%d", &t);
    while (t--) {
        int n, m, d;

        scanf("%d%d%d", &n, &m, &d);

        for (int i = 1; i <= n; ++i)
            G[i].clear();

        while (m--) {
            int a, b;
            scanf("%d%d", &a, &b);
            G[a].push_back(b);
            G[b].push_back(a);
        }

        for (int nn = 1; nn <= n; ++nn) {
            memset(dp, 0, sizeof(dp));
            for (int i = 1; i <= n; ++i)
                dp[0][i] = (1.0 / n);

            for (int k = 1; k <= d; ++k) {
                for (int i = 1; i <= n; ++i) {

                    if (i == nn) continue;

                    for (int j = 0; j < G[i].size(); ++j) {
                        int v = G[i][j];
                        if (v == nn) continue;
                        dp[k][v] += dp[k - 1][i] * (1.0 / G[i].size());
                    }

                }
            }

            double sum = 0;
            for (int i = 1; i <= n; ++i)
                sum += dp[d][i];

            printf("%.10lf\n", sum);
        }

    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值