HDU-2224 双调欧几里得旅行商问题

17 篇文章 0 订阅

Problem Description
There are n points on the plane, Pi(xi, yi)(1 <= i <= n), and xi < xj (i<j). You begin at P1 and visit all points then back to P1. But there is a constraint:
Before you reach the rightmost point Pn, you can only visit the points those have the bigger x-coordinate value. For example, you are at Pi now, then you can only visit Pj(j > i). When you reach Pn, the rule is changed, from now on you can only visit the points those have the smaller x-coordinate value than the point you are in now, for example, you are at Pi now, then you can only visit Pj(j < i). And in the end you back to P1 and the tour is over.
You should visit all points in this tour and you can visit every point only once.
Input
The input consists of multiple test cases. Each case begins with a line containing a positive integer n(2 <= n <= 200), means the number of points. Then following n lines each containing two positive integers Pi(xi, yi), indicating the coordinate of the i-th point in the plane.
Output
For each test case, output one line containing the shortest path to visit all the points with the rule mentioned above.The answer should accurate up to 2 decimal places.
Sample Input
3
1 1
2 3
3 1
Sample Output
6.47
我还是不会dp吖
代码:

#include<bits/stdc++.h>
#define maxn 205
using namespace std;
struct poi{
	double x,y;
}p[maxn];
bool cmp(poi a,poi b){return a.x<b.x;}
double dist(poi a,poi b){
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double d[maxn][maxn],dp[maxn][maxn];
//dp[i][j]表示p[i]到p[j]经过起点的最短距离
int main(){
	int n;
	while(~scanf("%d",&n)){
		for(int i=1;i<=n;++i)scanf("%lf%lf",&p[i].x,&p[i].y);
		sort(p+1,p+n+1,cmp);
		for(int i=1;i<=n;++i)
			for(int j=1;j<=n;++j){
				d[i][j]=dist(p[i],p[j]);
				dp[i][j]=1e9;
			}
		dp[1][1]=0;
		for(int i=1;i<=n;++i)
			for(int j=1;j<=i;++j){
			if(i==j)for(int k=1;k<=j;++k)
				dp[i][j]=min(dp[i][j],dp[j][k]+d[k][i]);
			if(i==j+1)for(int k=1;k<=j;++k)
				dp[i][j]=min(dp[i][j],dp[j][k]+d[k][i]);
			if(i>j+1)
				dp[i][j]=dp[i-1][j]+d[i-1][i];
		}
		printf("%.2lf\n",dp[n][n]);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值