HDU-1534 SPFA 差分约束

该项目描述了一个需要在最短时间内完成的任务调度问题,任务由不同部分组成,每个部分有固定完成时间。存在四种类型的约束条件:FAS、FAF、SAF和SAS,约束了部分之间的先后顺序。由于资源充足,可以同时进行多个部分。输入包含项目中各部分的时间和约束关系,输出是最短时间的调度方案。如果无法找到解决方案,则输出'Impossible'。
摘要由CSDN通过智能技术生成

Problem Description
A project can be divided into several parts. Each part should be completed continuously. This means if a part should take 3 days, we should use a continuous 3 days do complete it. There are four types of constrains among these parts which are FAS, FAF, SAF and SAS. A constrain between parts is FAS if the first one should finish after the second one started. FAF is finish after finish. SAF is start after finish, and SAS is start after start. Assume there are enough people involved in the projects, which means we can do any number of parts concurrently. You are to write a program to give a schedule of a given project, which has the shortest time.
Input
The input file consists a sequences of projects.
Each project consists the following lines:
the count number of parts (one line) (0 for end of input)
times should be taken to complete these parts, each time occupies one line
a list of FAS, FAF, SAF or SAS and two part number indicates a constrain of the two parts
a line only contains a ‘#’ indicates the end of a project
Output
Output should be a list of lines, each line includes a part number and the time it should start. Time should be a non-negative integer, and the start time of first part should be 0. If there is no answer for the problem, you should give a non-line output containing “impossible”.
A blank line should appear following the output for each project
Sample Input
3
2
3
4
SAF 2 1
FAF 3 2

3
1
1
1
SAF 2 1
SAF 3 2
SAF 1 3

0
Sample Output
Case 1:
1 0
2 2
3 1

Case 2:
impossible
代码:

#include<bits/stdc++.h>
#define maxn 1001
using namespace std;
inline int read(){
    int x=0,f=0;char ch=getchar();
    while(ch>'9'||ch<'0')f|=ch=='-',ch=getchar();
    while(ch>='0'&&ch<='9')x=(x<<3)+(x<<1)+(ch^48),ch=getchar();
    return f?-x:x;
}
vector<pair<int,int> >e[maxn];
int n,c[maxn],d[maxn],vis[maxn],in[maxn];
int SPFA(int s){
	memset(d,-0x3f,sizeof(d));
	memset(vis,0,sizeof(vis));
	memset(in,0,sizeof(in));
	queue<int>q;
	q.push(s);
	d[s]=0,vis[s]=in[s]=1;
	while(!q.empty()){
		int now=q.front();q.pop();
		vis[now]=0;
		if(in[now]>n)return 0;
		for(int i=0;i<e[now].size();++i){
			int v=e[now][i].first;
			if(d[v]<d[now]+e[now][i].second){
				d[v]=d[now]+e[now][i].second;
				if(!vis[v])q.push(v),vis[v]=1,++in[v];
			}
		}
	}
	return 1;
}
int main(){
	int cnt=0;
	while(n=read()){
		for(int i=0;i<=n;++i)e[i].clear();
		for(int i=1;i<=n;++i)c[i]=read(),e[0].push_back(make_pair(i,0));
		string op;
		while(cin>>op&&op[0]!='#'){
			int u=read(),v=read();
			if(op[0]=='S'&&op[2]=='S')e[v].push_back(make_pair(u,0));
			if(op[0]=='S'&&op[2]=='F')e[v].push_back(make_pair(u,c[v]));
			if(op[0]=='F'&&op[2]=='S')e[v].push_back(make_pair(u,-c[u]));
			if(op[0]=='F'&&op[2]=='F')e[v].push_back(make_pair(u,c[v]-c[u]));
		}
		printf("Case %d:\n",++cnt);
		if(SPFA(0))for(int i=1;i<=n;++i)printf("%d %d\n",i,d[i]);
		else puts("impossible");
		putchar('\n');
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值