HDU 1054——Strategic Game(树形DP)

Strategic Game

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4805    Accepted Submission(s): 2185


Problem Description
Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree: 

 

the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:
 

Sample Input
  
  
4 0:(1) 1 1:(2) 2 3 2:(0) 3:(0) 5 3:(3) 1 4 2 1:(1) 0 2:(0) 0:(0) 4:(0)
 

Sample Output
  
  
1 2

———————————————————————分割线—————————————————————————

题目分析

用最少的士兵将所有的道路都监控起来

这题是最小顶点覆盖,可以用二分匹配,但是今天学树形DP,走起~~


基础模板:

1、建图,用邻接表

2、dfs,遍历整个图,直到叶子,然后子问题一层一层往上合并成整个问题

额,都是废话~~~

状态转移 dp[i][0]  i节点不放士兵所需要的最少方案数,dp[i][1]  i节点放士兵的最少方案数

每个节点都有两个状态,放士兵或者不放士兵

1.如果该节点不放士兵,那么它的所有子节点必须放

2.如果该节点放士兵,那么它的子节点有两种决策,放或不放,去最小的


code^*^:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#define maxn 1510
using namespace std;
struct node
{
    int v,next;
}edge[maxn*maxn];
int e;
int head[maxn];
int dp[maxn][2];
int vis[maxn];
void dfs(int u)
{
    vis[u]=1;
    dp[u][1]=1;
    for(int e=head[u];e!=-1;e=edge[e].next){
        int v=edge[e].v;
        if(vis[v]) continue;
        dfs(v);      //dfs到最底层
        dp[u][1]+=min(dp[v][1],dp[v][0]);  //解决子问题
        dp[u][0]+=dp[v][1];
    }
}
void addedge(int u,int v)  //邻接表建图
{
    edge[e].v=v;
    edge[e].next=head[u];
    head[u]=e++;
    edge[e].v=u;
    edge[e].next=head[v];
    head[v]=e++;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF){
        memset(head,-1,sizeof head);
        memset(dp,0,sizeof dp);
        memset(vis,0,sizeof vis);
        int x,y,v,s=-1;
        e=0;
        while(n--){
            scanf("%d:(%d)",&x,&y);
            while(y--){
                scanf("%d",&v);
                addedge(x,v);
            }
            if(s==-1&&y) s=x;
        }
        dfs(s);
        printf("%d\n",dp[s][0]>dp[s][1]?dp[s][1]:dp[s][0]); //去最小
    }
    return 0;
}

——————vector建图

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<vector>
#define maxn 1510
using namespace std;
vector<int> g[maxn];
int dp[maxn][2];
int vis[maxn];
void dfs(int u)
{
    vis[u]=1;
    dp[u][1]=1;
    for(int i=0;i<g[u].size();i++){
        int v=g[u][i];
        if(vis[v]) continue;
        dfs(v);
        dp[u][1]+=min(dp[v][1],dp[v][0]);
        dp[u][0]+=dp[v][1];
    }
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF){
        memset(dp,0,sizeof dp);
        memset(vis,0,sizeof vis);
        int x,y,v,s=-1;
        for(int i=0;i<maxn;i++){
            g[i].clear();
        }
        while(n--){
            scanf("%d:(%d)",&x,&y);
            while(y--){
                scanf("%d",&v);
                g[x].push_back(v);
                g[v].push_back(x);
            }
            if(s==-1&&y) s=x;
        }
        dfs(s);
        printf("%d\n",dp[s][0]>dp[s][1]?dp[s][1]:dp[s][0]);
    }
    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值