HDU 1671——Phone List(Trie树)

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10865    Accepted Submission(s): 3746


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
  
  
NO YES
 

——————————————————————分割线————————————————

题目大意:

给你n个电话号码,判断存不存在某个电话号码是另外一个电话号码的前缀


思路:

基础的Trie树

但是有个特殊判断吧,插入某个电话号码的时候整个经过的全是之前已有的节点,那么也是某个电话号码的前缀


记得用递归写个删除,不然会爆内存


#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
const int maxn=10001;
const int sigma_size=10;
using namespace std;
bool flag;
struct Trie
{
    int val;
    Trie *next[sigma_size];
    Trie():val(0){memset(next,0,sizeof(next));}
};
Trie *root;
void insert(char *s)
{
    Trie *p=root;
    int l=strlen(s);
    int cnt=0;
    flag=true;
    for(int i=0;i<l;++i){
        int c=s[i]-'0';
        if(p->next[c]==NULL){
            p->next[c]=new Trie;
            p=p->next[c];
        }else{
            cnt++;
            p=p->next[c];
        }
        if(p->val) flag=false;
    }
    p->val=1;
    if(cnt==l) flag=false;
}
void del(Trie *p)
{
    for(int i=0;i<sigma_size;++i){
        if(p->next[i]!=NULL){
            del(p->next[i]);
        }
    }
    delete(p);
}
int main()
{
    int T;
    cin>>T;
    while(T--){
        root=new Trie;
        int n;
        scanf("%d",&n);
        char str[maxn];
        flag=true;
        while(n--){
            scanf("%s",str);
            if(flag){
                insert(str);
            }
        }
        if(flag) printf("YES\n");
        else printf("NO\n");
        del(root);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值