UVA Efficient Solutions (优势人群)——multiset、排序二叉树

Problem I
Efficient Solutions

Input: Standard Input

Output: Standard Output

"Our marriage ceremonies are solemn, sober
moments of reflection; also regret, disagreement,
argument and mutual recrimination. Once you know
it can't get any worse, you can relax and enjoy
the marriage."

J. Michael Straczynski, "The Deconstruction of Falling Stars."

The princess of Centauri Prime is the galaxy's most eligible bachelorette of the year. She has hopeful grooms lined up in front of the royal palace for a chance to spend 5 minutes to try and impress her. After 5 minutes, the gentleman is carried out of the royal chambers by the palace guards, and the princess makes a decision. She rates the lad on his lineage and charm by giving him a score for each of the two properties. On Centauri Prime, low scores are better than high scores.

Suppose that she observes two gentlemen - A and B. She assigns A the scores LA and CA (for lineage and charm, respectively). B receives scores LB and CB. Then A is dominatedby B if either

  • LB < LA and CB <= CA, or
  • LB <= LA and CB < CA.

In other words, if at least one of B's scores is better than A's, and the other score is not worse. She considers a gentleman to be efficient (or Pareto-optimal) if she has not yet met any other gentleman who dominates him. She maintains a list of efficient grooms and updates it after each 5-minute presentation.

Given the queue of bachelors and the scores assigned to them by the princess, determine the number of entries in the list of efficient grooms after each performance.

Input
The first line of input gives the number of cases, N (0<N<40)N test cases follow.

Each one starts with a line containing n (0≤n≤15000) - the size of the queue. The next n lines will each contain two scores (integers in the range [0, 109]). Initially, the list is empty.

Output
For each test case, output one line containing "Case #x:" followed by n lines, line i containing the size of the list of efficient grooms after the ith update. Print an empty line between test cases.

 

Sample Input

Sample Output

4
1
100 200
2
100 200
101 202
2
100 200
200 100
5
11 20
20 10
20 10
100 20
1 1
Case #1:
1
 
Case #2:
1
1
 
Case #3:
1
2
 
Case #4:
1
2
3
3
1



———————————————————————————分割线————————————————

题目大意:

有n个人,每个人有两个属性x和y。如果对于一个人p(x,y),不存在另外一个人(x',y'),使得x'<x,y'<=y,或者x'<=x,y'<y,我们说p是有优势的。每次给出一个人的信息,要求输出在只考虑当前已获得的信息的前提下,多少人是有优势的。


思路:

新增一个点p后,有两种情况:

1:p点本身没有优势

2:p点有优势,则把它加入到集合中,删除在它右上角的所有点


维护优势集合s

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<set>
using namespace std;
struct node
{
    int x,y;
    bool operator<(const node cmp)const{
        return x<cmp.x||(x==cmp.x&&y<cmp.y);
    }
};
multiset<node> s;
multiset<node>::iterator it;
int main()
{
//#ifndef ONLINE_JUDGE
//freopen("in.cpp","r",stdin);
//freopen("out.cpp","w",stdout);
//#endif // ONLINE_JUDGE
    int T;scanf("%d",&T);
    for(int kase=1;kase<=T;++kase){
        if(kase>1) printf("\n");
        printf("Case #%d:\n",kase);

        int n,x,y;
        scanf("%d",&n);
        s.clear();
        while(n--){
            scanf("%d%d",&x,&y);
            node p=(node){x,y};
            it=s.lower_bound(p);
            if(it==s.begin()||(--it)->y>y){
                s.insert(p);
                it=s.upper_bound(p);
                while(it!=s.end()&&it->y>=y){
                    s.erase(it++);
                }
            }
            printf("%d\n",s.size());
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值