BestCoder Round #43 HDU 5065 关于数字取余的问题

pog loves szh II

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 459    Accepted Submission(s): 123


Problem Description
Pog and Szh are playing games.There is a sequence with  n  numbers, Pog will choose a number A from the sequence. Szh will choose an another number named B from the rest in the sequence. Then the score will be  (A+B)  mod  p .They hope to get the largest score.And what is the largest score?
 

Input
Several groups of data (no more than  5  groups, n1000 ).

For each case: 

The following line contains two integers, n(2n100000) p(1p2311)

The following line contains  n  integers  ai(0ai2311)
 

Output
For each case,output an integer means the largest score.
 

Sample Input
  
  
4 4 1 2 3 0 4 4 0 0 2 2
 

Sample Output
  
  
3 2
 

Source
 
    原文地址

  官方题解:

<span style="font-size:18px;">#include <algorithm>
#include <iostream>
#include <cstdio>
using namespace std;
typedef long long LL;
const int MAXN = 100010;
LL a[MAXN];

int main()
{
    int n, p;
    while (cin >> n >> p)
    {
        for (int i = 0; i < n; ++i)
        {
            scanf("%d", &a[i]);
            a[i] %= p;
        }
        sort(a, a+n);
        LL ans = (a[n-1]+a[n-2])%p;
        int i = 0, j = n-1;
        while (i < j)
        {
            if (a[i] + a[j] >= p)
                --j;
            else
            {
                ans = max(ans, a[i]+a[j]);
                ++i;
            }
        }
        cout << ans << endl;
    }
    return 0;
}</span>





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值