ACM steps之三(Section Two)

这里我们看一下Section Two 的 1.2.8题的Lowest  Bit(最小有效位)

题目

Lowest Bit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1997 Accepted Submission(s): 1392
 
Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.
Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.
Output
For each A in the input, output a line containing only its lowest bit.
Sample Input
26
88
0
Sample Output
2
8

做题心得

一开始题目没弄懂,以为是输出二进制中从低位开始第一次遇到1的位置,后来查一下,这题是位运算,题意在上面,然后稍微改了一下代码

ac了,蛮高兴的,嘿嘿。

大致题意

设有一个十进制数k,当以二进制表示时,若从低位开始第一个1的位置为i,则2^i(2i次幂)即位lowest bit

比如:(6)10=(0110)2,那么此时i=1lowest bit2(8)10=(1000)2,那么此时i=3lowest bit8

 

代码

#include<stdio.h>
#include<math.h>
int main()
{
	int sz[7];
	int i,j,n,q;
	while((scanf("%d",& n)!=EOF)&&n!=0)
	{
		i=0;
		do
		{
			sz[i]=n%2;
			i++;
			n=n/2;
		}while(n!=0);
		for(j=0;j<i;j++)
		{
			if(sz[j]==0)
				;//空操作
			if(sz[j]==1)
			{
				q=pow(2,j);//求2的次方
				printf("%d\n",q);
				break;
			}
		}
	}
	return 0;
}

但我在网上发现了一段特别短的c++代码,还没弄懂

include<iostream>
using namespace std;
int main()
{
    int n;
    while(cin>>n,n)
        cout<<(n&-n)<<endl;//n&-n取得n最右边的1
}


其实它用的是位运算,大家可以看看它的解释

http://blog.sina.com.cn/s/blog_82c81ada0100upaq.html


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值