hdu 素数环1016

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2

#include<iostream>
using namespace std;

int N;
int PrimeCycle[20];
int visited[20];
bool IsPrime(int num)
{
    for (int i = 2; i*i <= num; i++)
    {
        if (num%i == 0)
            return false;
    }
    return true;

}
void dfs(int current,int size)
{
    if (size == N+1)
    {
        if (IsPrime(current + 1))
        {
            for (int i = 1; i < N; i++)
            {
                cout << PrimeCycle[i] << " ";
            }
            cout << PrimeCycle[N];
            cout << endl;
        }
        return;
    }
    else
    {
        for (int i = 2; i <= N; i++)
        {
            
            if (visited[i]==0 && IsPrime(current + i))
            {
                PrimeCycle[size] = i;
                visited[i] = 1;
                dfs(i,size+1);
                visited[i] = 0;
            }
        }
    }
}
int main()
{
    int Case = 1;
    PrimeCycle[1] = 1;
    while (cin >> N)
    {
        cout << "Case " << Case++ << ":" << endl;
        dfs(1, 2);
        cout << endl;
    }
    
    
    return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值