SGU - 117 - Counting (快速幂取模!)

SGU - 117

Time Limit: 250MS Memory Limit: 4096KB 64bit IO Format: %I64d & %I64u

 Status

Description

Find amount of numbers for given sequence of integer numbers such that after raising them to the M-th power they will be divided by K.

Input

Input consists of two lines. There are three integer numbers N, M, K(0<N, M, K<10001) on the first line. There are N positive integer numbers − given sequence (each number is not more than 10001) − on the second line.

Output

Write answer for given task.

Sample Input

4 2 50
9 10 11 12

Sample Output

1

Author: Michael R. Mirzayanov
Resource: PhTL #1 Training Contests
Date: Fall 2001

Source




题意:第一行先给出n,m,k三个整数,第二行给出n个整数,判断这些整数的m的次方是否能被k整除,,简单快速幂即可。。


AC代码:


#include <cstdio>
#include <cstring>
#include <algorithm>  
using namespace std;  

int q_pow(int n, int m, int k)  
{  
    int result=1;  
    while(m)  //快速幂 
    {  
        if(m&1)     //判断是否为奇数 
        result=(result*n)%k;   
        n=n*n%k;   
        m>>=1;  
    }  
    return result%k;  
}  

int main()  
{  
    int n, m, k;  
    while(scanf("%d %d %d", &n, &m, &k)!=EOF)  
    {  
        int ans = 0;  
        for(int i=0; i<n; i++)  
        {  
        	int a;
            scanf("%d", &a);  
            if(q_pow(a, m, k)==0)  ans++;  
        }  
        printf("%d\n", ans);  
    }  
    return 0;  
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值