UVA - 10881 - Piotr's Ants

23 篇文章 0 订阅

UVA - 10881

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

 Status

Description

Download as PDF

Problem D
Piotr's Ants
Time Limit: 2 seconds

"One thing is for certain: there is no stopping them;
the ants will soon be here. And I, for one, welcome our
new insect overlords."
Kent Brockman

Piotr likes playing with ants. He has n of them on a horizontal pole L cm long. Each ant is facing either left or right and walks at a constant speed of 1 cm/s. When two ants bump into each other, they both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each of the ants starts and which direction it is facing and wants to calculate where the ants will end up T seconds from now.

Input
The first line of input gives the number of cases, NN test cases follow. Each one starts with a line containing 3 integers: L , T and n  (0 <=  n <= 10000)  . The next n lines give the locations of the n ants (measured in cm from the left end of the pole) and the direction they are facing (L or R).

Output
For each test case, output one line containing "Case #x:" followed by n lines describing the locations and directions of the n ants in the same format and order as in the input. If two or more ants are at the same location, print "Turning" instead of "L" or "R" for their direction. If an ant falls off the pole beforeT seconds, print "Fell off" for that ant. Print an empty line after each test case.

Sample InputSample Output
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R
Case #1:
2 Turning
6 R
2 Turning
Fell off

Case #2:
3 L
6 R
10 R


Problemsetter: Igor Naverniouk
Alternate solutions: Frank Pok Man Chu and Yury Kholondyrev

Source

Root :: AOAPC I: Beginning Algorithm Contests -- Training Guide (Rujia Liu) :: Chapter 1. Algorithm Design :: General Problem Solving Techniques ::  Examples
Root :: Prominent Problemsetters ::  Igor Naverniouk (Abednego)







AC代码:

#include <cstdio> 
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;

const int maxn = 10005;

struct Ant {
	int id;		//输入顺序 
	int p;		//位置 
	int d;		//朝向。-1表示朝左;0表示正在碰撞;1表示朝右; 
	bool operator < (const Ant& a) const {		//用于sort函数 
		return p < a.p;
	}
}before[maxn], after[maxn];

const char dirName[][10] = {"L", "Turning", "R"}; 

int order[maxn]; //输入的第i只蚂蚁是终态中的左数第order[i]只蚂蚁 

int main() {
	int N, cas = 1;
	scanf("%d", &N);
	while(N--) {
		int L, T, n;
		printf("Case #%d:\n", cas++);
		scanf("%d %d %d", &L, &T, &n);
		for(int i = 0; i < n; i++) {
			int p, d;
			char c;
			scanf("%d %c", &p, &c);
			d = (c == 'L' ? -1: 1);
			before[i] = (Ant){i, p, d};			//初始状态 
			after[i] = (Ant){0, p+T*d, d};		//末状态 
		}
		
		//计算order数组
		sort(before, before+n);
		for(int i = 0; i < n; i++) 
			order[before[i].id] = i;
			
		//计算终态
		sort(after, after+n);
		for(int i = 0; i < n-1; i++) 
			if(after[i].p == after[i+1].p) after[i].d = after[i+1].d = 0;
		
		//输出结果 
		for(int i = 0; i < n; i++) {
			int a = order[i];		//a表示实际顺序 
			if(after[a].p < 0 || after[a].p > L) printf("Fell off\n");
			else printf("%d %s\n", after[a].p, dirName[after[a].d+1]); 
		}
		printf("\n");
	} 
	return 0;
} 







  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值