SGU - 403 - Scientific Problem (水)

403. Scientific Problem
Time limit per test: 0.25 second(s)
Memory limit: 65536 kilobytes
input: standard
output: standard



Once upon a time Professor Idioticideasinventor was travelling by train. Watching cheerless landscape outside the window, he decided to invent the theme of his new scientific work. All of a sudden a brilliant idea struck him: to develop an effective algorithm finding an integer number, which is  x times less than the sum of all its integer positive predecessors, where number  x is given. As far as he has no computer in the train, you have to solve this difficult problem.

Input
The first line of the input file contains an integer number  x (1 ≤  x ≤ 10 9).

Output
Output an integer number — the answer to the problem.

Example(s)
sample input
sample output
1
3

sample input
sample output
2
5




Online Contester Team © 2002 - 2010. All rights reserved.




思路:先给出一个数x,求出数n,使得n是n之前所有数(不包括n)的总和的1/x

由求和公式n*(n-1)/2/x = n 可得 n=2*x+1


AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int main() {
	int x;
	while(scanf("%d", &x) != EOF) {
		printf("%d\n", 2*x+1);
	}
	return 0;
} 















  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值