SGU - 404 - Fortune-telling with camomile

23 篇文章 0 订阅

404. Fortune-telling with camomile
Time limit per test: 0.25 second(s)
Memory limit: 65536 kilobytes
input: standard
output: standard



Masha loves Petya. The following question gives her no rest: does Petya love her too? The best way to find this out is a fortune-telling. There are plenty ways of fortune predicting, but Masha prefers fortune-telling with camomile more than others. It's rules are simple. You should take camomile into the right hand and start picking petals one by one. After each petal you should pronounce one phrase from the predefined list. Such phrases like "loves", "doesn't love", "loves sincerely", "doubts", "wants to date", "laughs" are usually used. Phrases are pronounced from the first to the last. The list of phrases is cyclic, so after the last phrase you should pronounce the first one. The phrase that you pronounce after the last petal will be an answer.

Since Masha doesn't want to go to the forest and look for camomiles, she asks you to write the program which will simulate the process.

Input
First line of the input file contains two integer numbers  N  and  M  (1 ≤  N  ≤ 100, 1 ≤  M  ≤ 100), the number of petals and the number of phrases. Each of the following  M  lines contains one phrase. Phrases consist only of latin letters and their lengths are between 1 and 100. 

Output
Output the resulting phrase.

Example(s)
sample input
sample output
6 4
loves
doesnt
sincerely
doubts
doesnt

sample input
sample output
9 3
loves
doesnt
hates
hates






思路:数花瓣,每一次念一个字符串.......取个模就OK啦.........


AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

char str[105][105];

int main() {
	int N, M;
	while(scanf("%d %d", &N, &M) != EOF) {
		for(int i = 1; i <= M; i++) {
			scanf("%s", str[i]);
		}
		int ans = N % M;
		if(ans == 0) ans = M;
		printf("%s\n", str[ans]);
	}
	return 0;
} 












  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值