UVA - 108 - Maximum Sum (简单贪心)

这篇博客介绍了UVA 108问题,即在一个二维正负整数数组中找到和最大的子矩形。问题描述了如何确定子矩形的和,并给出了输入输出格式。博主分享了一个AC(Accepted)代码来解决这个问题。
摘要由CSDN通过智能技术生成

UVA - 108

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

 Status

Description

Download as PDF

Background

A problem that is simple to solve in one dimension is often much more difficult to solve in more than one dimension. Consider satisfying a boolean expression in conjunctive normal form in which each conjunct consists of exactly 3 disjuncts. This problem (3-SAT) is NP-complete. The problem 2-SAT is solved quite efficiently, however. In contrast, some problems belong to the same complexity class regardless of the dimensionality of the problem.

The Problem

Given a 2-dimensional array of positive and negative integers, find the sub-rectangle with the largest sum. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. A sub-rectangle is any contiguous sub-array of size tex2html_wrap_inline33 or greater located within the whole array. As an example, the maximal sub-rectangle of the array:

displaymath35

is in the lower-left-hand corner:

displaymath37

and has the sum of 15.

Input and Output

The input consists of an tex2html_wrap_inline39 array of integers. The input begins with a single positive integer N on a line by itself indicating the size of the square two dimensional array. This is followed by tex2html_wrap_inline43 integers separated by white-space (newlines and spaces). These tex2html_wrap_inline43 integers make up the array in row-major order (i.e., all numbers on the first row, left-to-right, then all numbers on the second row, left-to-right, etc.). N may be as large as 100. The numbers in the array will be in the range [-127, 127].

The output is the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7  0 9  2 -6  2
-4  1 -4  1 -1
8  0 -2

Sample Output

15

Source

Root :: Competitive Programming 2: This increases the lower bound of Programming Contests. Again (Steven & Felix Halim) :: Problem Solving Paradigms :: Dynamic Programming ::  Max Sum
Root :: AOAPC I: Beginning Algorithm Contests (Rujia Liu) ::  Volume 4. Algorithm Design
Root :: Competitive Programming: Increasing the Lower Bound of Programming Contests (Steven & Felix Halim) :: Chapter 3. Problem Solving Paradigms :: Dynamic Programming ::  Maximum Sum
Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: Problem Solving Paradigms :: Dynamic Programming ::  Max 2D Range Sum

 Status





AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#define LL long long
#define INF 0xffffffff
using namespace std;

int N;
int a[105][105];
int sum[105][105];

int main() {
	while(scanf("%d", &N) != EOF) {
		for(int i = 1; i <= N; i++) {
			for(int j = 1; j <= N; j++) {
				scanf("%d", &a[i][j]);
			}
		}
		
		memset(sum, 0, sizeof(sum));
		for(int i = 1; i <= N; i++) {
			int t = 0;
			for(int j = 1; j <= N; j++) {
				t += a[i][j];
				sum[i][j] = sum[i - 1][j] + t;
				//printf("%d ", sum[i][j]);
			}
			//printf("%d\n");
		}
		
		int p, q, ans = INF;
		for(int i = 1; i < N; i++) {
			for(int j = 1; j < N; j++) {
				for(int k = i; k <= N; k++) {
					for(int l = j; l <= N; l++) {
						int tmp = sum[k][l] - sum[i-1][l] - sum[k][j-1] + sum[i-1][j-1];
						if(tmp > ans) ans = tmp;
					}
				}
			}
		}
		
		printf("%d\n", ans);
	}
	return 0;
}

















  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值