POJ Ants(uva 10714 && 水题)

Ants
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 10645 Accepted: 4722

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207
 
n只蚂蚁在一个长为l的横杆上运动,给出这些蚂蚁距最左端的距离(运动方向不知),两只蚂蚁碰头后会分别向相反的方向运动,问这些蚂蚁全部掉下横杆的最短时间,和最长时间
这题刚一看,很麻烦的就是处理碰头问题,然后最坑的是你会发现,两只蚂蚁碰头后,什么都没有变化,仅仅是这两只蚂蚁交换了运动的方向,所以最长掉落时间就是每只蚂蚁距端点最长距离中的一个最大值,最短时间就是这些蚂蚁距端点最小值中的一个最大值
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#define MAX 0x3f3f3f3f
using namespace std;
int main()
{
     int T;
     scanf("%d",&T);
     while(T--)
     {
       int l,n;
       scanf("%d%d",&l,&n);
       int mmax=-1;
       int mmin=-1;
       for(int i=0;i<n;i++)
       {
          int x;
          scanf("%d",&x);
          mmax=max(mmax,x);
          mmax=max(mmax,l-x);
          mmin=max(mmin,min(x,l-x));
       }
       printf("%d %d\n",mmin,mmax);
     }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值