POJ 2115 C Looooops(单变元模线性方程)

16 篇文章 0 订阅
C Looooops
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20180 Accepted: 5422

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER
 
求 Cx - (2^k)y = B-A中x的最小值
即求 ax - by = c;
先用扩展欧几里得求出  ax - by = gcd(a,b)的解(x,y)
如果c不能整除gcd(a,b)则无解
ax - by = gcd(a,b) 等式两边同时* c/gcd(a,b)得
ax * c/gcd(a,b) - by * c/gcd(a,b) = c
最后的解为 x * c/(gcd) 对 b/gcd(a,b)取余
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <algorithm>
#include <queue>
#include <map>
#include <cmath>
#define N 1001
#define ll long long int
#define eps 1e-8
#define PI acos(-1.0)
#define inf 0x3f3f3f3f
using namespace std;
ll x, y;
ll gcd(ll a,ll b)
{
    if(b == 0)
    {
        x = 1;
        y = 0;
        return a;
    }
    ll c = gcd(b, a%b);
    ll t = x;
    x = y;
    y = t - (a/b)*y;
    return c;
}
int main()
{
    ll A, B, C, k;
    while(~scanf("%I64d%I64d%I64d%I64d", &A, &B, &C, &k))
    {
        if(!A && !B && !C && !k)
            break;
        ll a = C;
        ll b = pow(2,k);
        ll c = B - A;
        ll gg = gcd(a, b);
        if(c%gg)
        {
            printf("FOREVER\n");
            continue;
        }
        x = x * (c/gg) ;      // ax - by = gg 变为  ax * c/gg - by * c/gg = c
        x = (x%(b/gg) + b/gg) % (b/gg);   // x = x+k*( b/gg ) 求最小解
        printf("%I64d\n",x);

    }
    return 0;
}



                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值