ACM: 一题数论题(扩展欧几里得定理…

                                                                        C Looooops

Description

A Compiler Mystery: We are given a C-language style for loop of type
for (variable = A; variable != B; variable += C)
statement;
I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

Sample Input

3 3 2 16

3 7 2 16

7 3 2 16

3 4 2 16

0 0 0 0

Sample Output

0

2

32766

FOREVER 

 

题意: for(i = A; (i mod 2^k) != B; ++i) 计算循环的次数.死循环输出FOREVER. 

个人思路:

               1.(A + C*i mod 2^k) =?= B

               2.同余运算:    (0 <= A, B, C < 2^k)

                ( (A mod 2^k)+(C*i mod 2^k) ) mod 2^k = B

              => (A + (C*i mod 2^k) ) mod 2^k = B

              => (C*i mod 2^k) - 2^k * t1 = B-A

              => C*i - 2^k * t2 - 2^k * t1 = B-A

              => C*i - 2^k * t = B-A

               3.熟悉的扩展欧几里得: ax + by = gcd(a,b); 

这里进一步证明:

              我可以先求出: a * X0 + b * Y0 = gcd(a,b);

             两边同时除以gcd(a,b)  得: (a * X0) / gcd(a,b) + (b * Y0) / gcd(a,b) = 1;

             两边同时乘以n 得: n * (a * X0) / gcd(a,b) + n * (b * Y0) / gcd(a,b) = n;

           即:  x = X0 / gcd(a,b) * n       y = Y0 / gcd(a,b) * n;

 若 (a,b)=1  且 x0 , y0 为方程 a*x+b*y=n的一组解  ,那么 x=x0+b*t ,y=y0-a*t  (t为任意整数) 都是方程的解.

而往往题目中要求求最小的解 , 那么我们就可以将一个特解x , t = b / (a,b) , x=(x%t+t) % t; 就可以了

代码: 

#include <iostream>
#include <cstdio>
using namespace std;

void exgcd(__int64 a,__int64 b, __int64 &d,__int64 &x,__int64 &y)
{
       if( b == 0 )
      {
              d = a , x = 1, y = 0;
       }
      else
      {
             exgcd(b,a%b,d,y,x);
             y -= x*(a/b);
      }
}


int main()
{
          __int64 A , B , C , k;

          while(scanf("%I64d %I64d %I64d %I64d",&A,&B,&C,&k) != EOF)
         {
                  if(A == 0 && B == 0 && C == 0 && k == 0)
                          break;

                 __int64 x , y;
                 __int64 d;
                 __int64 K = 1;
                 for(int i = 1; i <= k; ++i)
                {
                       K = K * 2;
                 }
                 exgcd(C,K,d,x,y);
  
                 if((B-A) % d != 0)
                {
                        printf("FOREVER\n");
                }
                else
               {
                          __int64 t = x * (B-A) / d;
                          __int64 result = (t % (K/d) + (K/d)) % (K / d);                          

                          printf("%I64d\n",result);
                 }

           }

          return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值