10、二叉树:重载运算符==

问题描述 :

内容:(1)请参照链表的ADT模板,设计二叉树并逐步完善的抽象数据类型。(由于该环境目前仅支持单文件的编译,故将所有内容都集中在一个源文件内。在实际的设计中,推荐将抽象类及对应的派生类分别放在单独的头文件中。参考教材、课件,以及网盘中的链表ADT原型文件,自行设计二叉树的ADT。)

注意:二叉树ADT的基本操作的算法设计很多要用到递归的程序设计方法。

 

(2)基本操作15:在二叉树的二叉链表存储形式建立的基础上,使用递归的程序设计方法,设计并完成重载运算符==的算法,用来判断两棵二叉树是否相同。所谓两棵树相同是指树的形状及对应结点的值均相同。完成后将其加入到二叉树的ADT基本操作集中。

初始条件:二叉树T1,T2。

操作结果:若T1和T2相同,返回true。否则,返回false。

 

参考函数原型:

(1)//运算符==重载函数(外壳部分,成员函数形式重载)

//运算符==重载函数  

template<class ElemType>

bool BinaryTree<ElemType>::operator ==(const BinaryTree<ElemType> &T);

 

(2)运算符==重载函数(递归部分,私有成员函数)

//运算符==重载函数

template<class ElemType>

bool BinaryTree<ElemType>::checkEqual(const BinaryTreeNode<ElemType> *root1, const BinaryTreeNode<ElemType> *root2);

 

输入说明 :

第一行:表示无孩子或指针为空的特殊分隔符

第二行:二叉树T1的先序序列(结点元素之间以空格分隔)

第三行:二叉树T2的先序序列(结点元素之间以空格分隔)

 

输出说明 :

第一行:T1与T2相同:true;否则:false

  

输入范例 :

#
A B # C D # # E # # F # G # H # #
A B # C D # # E # # F # G # H # #

输出范例 :

true

思路:

如果A指针的左孩子和右孩子的空、非空状态和元素与B的相同则继续递归

否则修改标记变量。

// tree.cpp : 此文件包含 "main" 函数。程序执行将在此处开始并结束。
//
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <sstream>
#include <stack>
#include <map>
#include <ctime>
#include <array>
#include <set>
using namespace std;
vector<string> departString_string(string data)
{
	vector<int> back_part;//output type
	int i, j;
	vector<string> part;
	string A_part;
	stringstream room;
	room.str(data);
	while (room >> A_part)
		part.push_back(A_part);
	return part;
}
//————————————————
//版权声明:本文为CSDN博主「systemyff」的原创文章,遵循CC 4.0 BY - SA版权协议,转载请附上原文出处链接及本声明。
//原文链接:https ://blog.csdn.net/u014377763/article/details/113845555
template<class ElemType>
struct tree_point {
	ElemType data;//数据
	struct tree_point* l_child, * r_child;//左、右孩子指针
};
template<class ElemType>
class BinaryTree {
private:
	vector<tree_point<ElemType>*> outlist;
	tree_point<ElemType>* root;   // 头指针
public:
	BinaryTree() :root(NULL)
	{
		//无参数的构造函数
	}
	~BinaryTree()
	{
		//析构函数
	}
	void BinaryTree_fron(vector<ElemType> lis, ElemType nut)
	{
		stack<tree_point<ElemType>*> s;
		tree_point<ElemType>* p_Parent = NULL, * p_Child = NULL;
		int i = 0;
		int flag = 0;//控制左右
		p_Parent = new tree_point<ElemType>;
		p_Parent->data = lis[i];
		p_Parent->l_child = p_Parent->r_child = NULL;
		s.push(p_Parent);
		root = p_Parent;
		i = 1;
		flag = 0;
		while (!s.empty())
		{
			if (lis[i] != nut)
			{
				p_Parent = new tree_point<ElemType>;
				p_Parent->data = lis[i];
				p_Parent->l_child = p_Parent->r_child = NULL;
				if (flag == 0)
				{
					p_Child = s.top();
					p_Child->l_child = p_Parent;
				}
				else if (flag == 1)
				{
					p_Child = s.top();
					s.pop();
					p_Child->r_child = p_Parent;
				}
				s.push(p_Parent);
				flag = 0;
			}
			else
			{
				if (flag == 0)
					flag = 1;
				else if (flag == 1)
					s.pop();
			}
			i++;
		}
	}

	tree_point<ElemType>* get_root()
	{
		return root;
	}
	void qianxu(tree_point<ElemType>* t)
	{
		outlist.push_back(t);
		if (t->l_child != NULL)
			qianxu(t->l_child);
		if (t->r_child != NULL)
			qianxu(t->r_child);
		return;
	}
	void zhongxu(tree_point<ElemType>* t)
	{
		if (t->l_child != NULL)
			zhongxu(t->l_child);
		outlist.push_back(t);
		if (t->r_child != NULL)
			zhongxu(t->r_child);
		return;
	}
	void houxu(tree_point<ElemType>* t)
	{
		if (t->l_child != NULL)
			houxu(t->l_child);
		if (t->r_child != NULL)
			houxu(t->r_child);
		outlist.push_back(t);
		return;
	}
	int c_t = 0;
	void cengxu(tree_point<ElemType>* t)
	{
		vector<tree_point<ElemType>* > q;
		q.push_back(t);
		int last = 1, cur = 0;
		while (cur < q.size())
		{
			last = q.size();
			while (cur < last)
			{
				outlist.push_back(q[cur]);
				if (q[cur]->l_child)
					q.push_back(q[cur]->l_child);
				if (q[cur]->r_child)
					q.push_back(q[cur]->r_child);
				++cur;
			}
			c_t++;
		}
	}
	void out_lis()
	{
		int i;
		for (i = 0; i < outlist.size(); i++)
		{
			cout << outlist[i]->data;
			if (i != outlist.size() - 1)
				cout << ",";
			else
				cout << endl;
		}
		outlist.clear();
	}
	int cnt = 0, p_cnt = 0;
	void t_cnt(tree_point<ElemType>* t)
	{
		p_cnt++;
		if (t->l_child != NULL && t->r_child != NULL)
			cnt++;
		if (t->l_child != NULL)
			t_cnt(t->l_child);
		if (t->r_child != NULL)
			t_cnt(t->r_child);
	}
	int cengshu()
	{
		c_t = 0;
		cengxu(root);
		outlist.clear();
		return c_t;
	}
	int P_cengshu(tree_point<ElemType>* t)
	{
		c_t = 0;
		cengxu(t);
		outlist.clear();
		return c_t;
	}
	int twocnt()
	{
		cnt = 0;
		t_cnt(root);
		return cnt;
	}
	int P_twocnt(tree_point<ElemType>* t)
	{
		cnt = 0;
		t_cnt(t);
		return cnt;
	}
	int pointcnt()
	{
		p_cnt = 0;
		t_cnt(root);
		return p_cnt;
	}
	tree_point<ElemType>* father_p;
	void find_fatherNow(tree_point<ElemType>* t, ElemType ss)
	{
		if (t->l_child != NULL)
			if (t->l_child->data == ss)
			{
				father_p = t;
				return;
			}
		if (t->r_child != NULL)
			if (t->r_child->data == ss)
			{
				father_p = t;
				return;
			}
		if (t->l_child != NULL)
			find_fatherNow(t->l_child, ss);
		if (t->r_child != NULL)
			find_fatherNow(t->r_child, ss);
		return;
	}
	tree_point<ElemType>* find_father(tree_point<ElemType>* t, ElemType ss)
	{
		father_p = NULL;
		find_fatherNow(t, ss);
		return father_p;
	}
	tree_point<ElemType>* nas_p;
	void find_selfNOW(tree_point<ElemType>* t, ElemType ss)
	{
		if (t->data == ss)
			nas_p = t;
		if (t->l_child != NULL)
			find_selfNOW(t->l_child, ss);
		if (t->r_child != NULL)
			find_selfNOW(t->r_child, ss);
		return;
	}
	tree_point<ElemType>* find_self(tree_point<ElemType>* t, ElemType ss)
	{
		nas_p = NULL;
		find_selfNOW(t, ss);
		return nas_p;
	}
	void fast_delChild(tree_point<ElemType>* t, bool flag)
	{
		if (flag == 0)
			t->l_child = NULL;
		else
			t->r_child = NULL;
		return;
	}
	void slow_delChild(tree_point<ElemType>* t, bool flag)
	{
		if (flag == 0)
			t->l_child = NULL;
		else
			t->r_child = NULL;
		return;
	}
	bool is_same = 1;
	bool check_same(tree_point<ElemType>* t1, tree_point<ElemType>* t2)
	{
		if (((t1->l_child != NULL && t2->l_child != NULL) || (t1->l_child == NULL && t2->l_child == NULL))
			&& ((t1->r_child != NULL && t2->r_child != NULL) || (t1->r_child == NULL && t2->r_child == NULL))
			&& t1->data == t2->data)
		{
			if (t1->l_child != NULL)
				check_same(t1->l_child,t2->l_child);
			if (t1->r_child != NULL)
				check_same(t1->r_child, t2->r_child);
		}
		else
		{
			is_same = 0;
			return 0;
		}

	}
	bool operator==(BinaryTree B2)
	{
		is_same = 1;
		check_same(root, B2.get_root());
		return is_same;
	}
};

int main()
{
	string s, ins, ins1, nulls;
	vector<string> part_in, part_in1;
	BinaryTree<string> a;
	BinaryTree<string> b;
	cin >> nulls;
	cin.get();
	getline(cin, ins);
	getline(cin, ins1);
	part_in = departString_string(ins);
	part_in1 = departString_string(ins1);
	a.BinaryTree_fron(part_in, nulls);
	b.BinaryTree_fron(part_in1, nulls);
	if (a == b)
		cout << "true" << endl;
	else
		cout << "false" << endl;
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值