Box UVa 1587

2 篇文章 0 订阅

盒子
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF
Ivan works at a factory that produces heavy machinery. He has a simple job -- he knocks up wooden boxes of different sizes to pack machinery for delivery to the customers. Each box is a rectangular parallelepiped. Ivan uses six rectangular wooden pallets to make a box. Each pallet is used for one side of the box.
\epsfbox{p3214.eps}
Joe delivers pallets for Ivan. Joe is not very smart and often makes mistakes -- he brings Ivan pallets that do not fit together to make a box. But Joe does not trust Ivan. It always takes a lot of time to explain Joe that he has made a mistake. Fortunately, Joe adores everything related to computers and sincerely believes that computers never make mistakes. Ivan has decided to use this for his own advantage. Ivan asks you to write a program that given sizes of six rectangular pallets tells whether it is possible to make a box out of them.

Input 

Input file contains several test cases. Each of them consists of six lines. Each line describes one pallet and contains two integer numbers w and  h (  1$ \le$wh$ \le$10 000) -- width and height of the pallet in millimeters respectively.

Output 

For each test case, print one output line. Write a single word `  POSSIBLE' to the output file if it is possible to make a box using six given pallets for its sides. Write a single word `  IMPOSSIBLE' if it is not possible to do so.

Sample Input 

1345 2584
2584 683
2584 1345
683 1345
683 1345
2584 683
1234 4567
1234 4567
4567 4321
4322 4567
4321 1234
4321 1234

Sample Output 

POSSIBLE
IMPOSSIBLE

题意:给出六个矩形的长和宽,判断它们能否构成长方体的六个面。


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<queue>
#include<set>
#include<stack>
#include<algorithm>
#include<cstdlib>
#define maxn 20
using namespace std;

struct Node
{
    int x,y;
}st[maxn];

int cmp(Node a,Node b)
{
    if (a.x==b.x)
        return a.y<b.y;
    return a.x<b.x;
}

int main()
{
    int a,b;
    while (~scanf("%d",&a))
    {
        int flag=1;
        scanf("%d",&b);
        if (a>b) swap(a,b);
        st[0].x=a,st[0].y=b;
        for (int i=1;i<6;i++)
        {
            scanf("%d%d",&a,&b);
            if (a>b) swap(a,b);     //把较小的边放在前面
            st[i].x=a; st[i].y=b;
        }
        sort(st,st+6,cmp);      //排序
        for (int i=0;i<6;i+=2)
        {
            if (!(st[i].x==st[i+1].x&&st[i].y==st[i+1].y)) //如果每两个相邻的面的x和y不相等一定不满足
            {
                flag=0;
                break;
            }
        }
        if (flag)
        {
            if (st[0].x!=st[2].x)   //不同面的最小的两条边不能重合的不满足
                flag=0;
            if (!((st[0].y==st[4].x&&st[2].y==st[4].y)||(st[0].y==st[4].y&&st[2].y==st[4].x)))//判断第三个面能否与前两个面相接
                flag=0;
        }
        if (flag)
            printf("POSSIBLE\n");
        else
            printf("IMPOSSIBLE\n");
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值