hdu-1238

http://acm.hdu.edu.cn/showproblem.php?pid=1238

Substrings

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7444    Accepted Submission(s): 3358


Problem Description
You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.
 

Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string. 
 

Output
There should be one line per test case containing the length of the largest string found.
 

Sample Input
  
  
2 3 ABCD BCDFF BRCD 2 rose orchid
 

Sample Output
  
  
2 2
 

Author
Asia 2002, Tehran (Iran), Preliminary
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1239  1401  1548  1515  1180 
 

求最大公共子序列 暴力枚举


#include<stdio.h>
#include<iostream>
#include<math.h>
#include<stdlib.h>
#include<ctype.h>
#include<algorithm>
#include<vector>
#include<string.h>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<sstream>
#include<time.h>
#include<utility>
#include<malloc.h>
#include<stdexcept>

using namespace std;

char p[110][110];

int main ()
{
    int t,m,l;
    cin>>t;
    while ( t-- )
    {
        int n;
        cin>>n;
        m = 1000;
        for(int i=0;i<n;i++)
            {
                cin>>p[i];
                 if ( m > strlen (p[i]))
                 {
                     m = strlen(p[i]);
                     l = i;
                 }
            }
            
        char os[110],ps[110];
		int ans = 0;

        for(int i=0;i<strlen(p[l]);i++)
            {
                for(int  j= i;j<strlen(p[l]);j++ )
                {
                    int b = 0;
					int c = j-i;
                    for(int k = i;k<=j;k++)
                    {
                        os[b++] = p[l][k];
                        ps[c--] = p[l][k]; 
                    }

					os[b] = '\0';
					ps[j-i+1] = '\0';

					int ok =1;

					for(int k =0;k<n;k++)
					{
						 if (!strstr(p[k],os) && !strstr (p[k],ps))
						 {
							 ok = 0;
							 break;
						 }
					}
					 
					if (ok && ans < strlen(ps))
					{
						ans = strlen(ps);
					}
                }
            }
		cout<<ans<<endl;
    }
    return 0;
}



 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值