hduoj1238,Substrings,搜索,练习string的使用

7 篇文章 0 订阅

Substrings

Problem Description
You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.

Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string. 
 
Output
There should be one line per test case containing the length of the largest string found.
 
Sample Input
2
3
ABCD
BCDFF
BRCD
2
rose
orchid

Sample Output
2
2

分析:
熟练使用string的find,substr,以及反串使用reverse函数。

code:
#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
string s[100+5];
bool cmp(string s1,string s2)
{
    return s1.length()<s2.length();
}
int main()
{
    int t,n,len;
    bool ok;
    scanf("%d",&t);
    while(t--)
    {
        len=0;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            cin>>s[i];
        sort(s,s+n,cmp);
        for(int i=0;i<s[0].length();i++)
        for(int j=1;j<=s[0].length()-i;j++)
        {
            ok=true;
            string tmp=s[0].substr(i,j);
            for(int k=1;k<n;k++)
            {
                if(s[k].find(tmp)==string::npos)
                {
                    reverse(tmp.begin(),tmp.end());
                    if(s[k].find(tmp)==string::npos)
                    {
                        ok=false;
                        break;
                    }
                }
            }
            if(ok)
                if(len<j) len=j;
        }
        printf("%d\n",len);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值