poj 2992 Divisors n!的因子个数的计算

Divisors
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10399 Accepted: 3075

Description

Your task in this problem is to determine the number of divisors of  Cnk. Just for fun -- or do you need any special reason for such a useful computation?

Input

The input consists of several instances. Each instance consists of a single line containing two integers n and k (0 ≤ k ≤ n ≤ 431), separated by a single space.

Output

For each instance, output a line containing exactly one integer -- the number of distinct divisors of  Cnk. For the input instances, this number does not exceed 2 63 - 1.

Sample Input

5 1
6 3
10 4

Sample Output

2
6
16

//poj 2992

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<vector>
#include<stack>
#include<queue>
#include<set>
#include<map>
#include<cmath>
using namespace std;
typedef long long LL;
const int MAX=0xfffffff;
const int mx=450;
int prime[mx],nprime;
bool isprime[mx];
void make_prime()
{
    nprime=0;
    memset(isprime,1,sizeof(isprime));
    for(int i=2;i<mx;i++)
        if(isprime[i])
        {
            prime[++nprime]=i;
            for(int j=i*i;j<mx;j+=i)
                isprime[j]=0;
        }
}
int cal(int n,int p)  //计算n!中p的个数
{
    if(n<p)  return 0;
    return n/p+cal(n/p,p);
}
int main( )
{
    //freopen("1.txt","r",stdin);
    make_prime();
    int n,k;
    while(scanf("%d %d",&n,&k)!=EOF)
    {
        LL m=1;
        for(int i=1;prime[i]<=n;i++)
            m*=LL(cal(n,prime[i])-cal(n-k,prime[i])-cal(k,prime[i])+1); //n!/(n-k)!k!
        printf("%I64d\n",m);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值