hdoj 2579 Dating with girls(2) (BFS)

Dating with girls(2)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1923    Accepted Submission(s): 542


Problem Description
If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity!
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there.
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down.
 

Input
The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10).
The next r line is the map’s description.
 

Output
For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".
 

Sample Input
  
  
1 6 6 2 ...Y.. ...#.. .#.... ...#.. ...#.. ..#G#.
 

Sample Output
  
  
7
 

Source
 
解题思路:关键在于时间的状态表示,开始只用二维的WA掉,需要增加一维记录%k的余数。。不过的可试试这组样例:
3 3 5
Y##
..#
##G

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int N = 110;

struct Point{
    int x, y;
    int step;
    int time;
}start, fr, next;
char mp[N][N];
int vis[N][N][15];
int dir[4][2] = {1, 0, 0, -1, 0, 1, -1, 0};
int n, m, k;

void bfs(){
    queue<Point> Q;
    Q.push(start);
    while(!Q.empty()){
        fr = Q.front();
        Q.pop();
        if(mp[fr.x][fr.y] == 'G'){
            printf("%d\n", fr.step);
            return;
        }
        for(int i = 0; i < 4; i++){
            next.x = fr.x + dir[i][0];
            next.y = fr.y + dir[i][1];
            next.time = (fr.time + 1) % k;
            if(mp[next.x][next.y] == '\0') continue;
            if(next.time != 0 && mp[next.x][next.y] == '#') continue;
            if(!vis[next.x][next.y][next.time]){
                vis[next.x][next.y][next.time] = 1;
                next.step = fr.step + 1;
                Q.push(next);
            }
        }
    }
    puts("Please give me another chance!");
    return;
}

int main(){
    int T;
    scanf("%d", &T);
    while(T--){
        memset(mp, '\0', sizeof(mp));
        scanf("%d%d%d", &n, &m, &k);
        for(int i = 1; i <= n; i++){
            scanf("%s", mp[i] + 1);
            for(int j = 1; j <= m; j++){
                if(mp[i][j] == 'Y'){
                    start.x = i;
                    start.y = j;
                    start.step = 0;
                    start.time = 0;
                }
            }
        }
        memset(vis, 0, sizeof(vis));
        bfs();
    }
    return 0;
}
/*
4
3 3 1
Y#.
#..
..G
3 3 5
Y##
..#
##G
*/




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值