hdoj 2258 Continuous Same Game (1) (DFS+模拟)

没什么意思,,根据题意模拟出过程就好。。

Continuous Same Game (1)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 412    Accepted Submission(s): 145


Problem Description
Continuous Same Game is a simple game played on a grid of colored blocks. Groups of two or more connected (orthogonally, not diagonally) blocks that are the same color may be removed from the board. When a group of blocks is removed, the blocks above those removed ones fall down into the empty space. When an entire column of blocks is removed, all the columns to the right of that column shift to the left to fill the empty columns. Points are scored whenever a group of blocks is removed. The number of points per block increases as the group becomes bigger. When N blocks are removed, N*(N-1) points are scored.

LL was interested in this game at one time, but he found it is so difficult to find the optimal scheme. So he always play the game with a greedy strategy: choose the largest group to remove and if there are more than one largest group with equal number of blocks, choose the one which contains the most preceding block ( (x1,y1) is in front of (x2,y2) if and only if (x1<x2 || x1==x2 && y1<y2) ). Now, he want to know how many points he will get. Can you help him?
 

Input
Each test case begins with two integers n,m ( 5<=n,m<=20 ), which is the size of the board. Then n lines follow, each contains m characters, indicating the color of the block. There are 5 colors, and each with equal probability.
 

Output
For each test case, output a single line containing the total point he will get with the greedy strategy.
 

Sample Input
  
  
5 5 35552 31154 33222 21134 12314
 

Sample Output
  
  
32
Hint
35552 00552 00002 00002 00000 00000 31154 05154 05104 00004 00002 00000 33222 01222 01222 00122 00104 00100 21134 21134 21134 25234 25234 25230 12314 12314 12314 12314 12314 12312 The total point is 12+6+6+2+6=32.
 
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N = 25;

char mp[N][N];
int vis[N][N];
int dir[4][2] = {1, 0, 0, 1, -1, 0, 0, -1};
int n, m;
int cnt;

void dfs1(int x, int y, char c){
    vis[x][y] = 1;
    cnt++;
    for(int i = 0; i < 4; i++){
        int xx = x + dir[i][0];
        int yy = y + dir[i][1];
        if(mp[xx][yy] == c && !vis[xx][yy]) dfs1(xx, yy, c);
    }
}

void dfs2(int x, int y, char c){
    mp[x][y] = 0;
    for(int i = 0; i < 4; i++){
        int xx = x + dir[i][0];
        int yy = y + dir[i][1];
        if(mp[xx][yy] == c) dfs2(xx, yy, c);
    }
}

int main(){
    while(scanf("%d%d", &n, &m) != EOF){
        memset(mp, '\0', sizeof(mp));
        for(int i = 1; i <= n; i++){
            scanf("%s", mp[i] + 1);
            for(int j = 1; j <= m; j++){
                if(mp[i][j] == '0') mp[i][j] = 0;
            }
        }
        int ans = 0;
        while(true){
            memset(vis, 0, sizeof(vis));
            int Max = -1, mx, my;
            for(int i = 1; i <= n; i++)
            for(int j = 1; j <= m; j++){
                if(mp[i][j] && !vis[i][j]){
                    cnt = 0;
                    dfs1(i, j, mp[i][j]);
                 //   cout << "cnt = " << cnt << endl;
                    if(cnt > Max){
                        mx = i; my = j;
                        Max = cnt;
                    }
                }
            }
            if(Max < 2) break;
          //  cout << "Max = " << Max << endl;
            ans += Max * (Max - 1);
            dfs2(mx, my, mp[mx][my]);
            for(int j = 1; j <= m; j++){
                int k, flag = 0;
                if(mp[n][j]) flag = 1;
                for(int i = n - 1; i > 0; i--){
                    if(mp[i][j]){
                        flag = 1; k = i;
                        while(k < n && mp[k + 1][j] == 0){
                            mp[k + 1][j] = mp[k][j];
                            mp[k][j] = 0;
                            k++;
                        }
                    }
                }
                if(flag) continue;
                for(int i = 1; i <= n; i++)
                    for(k = j; k > 0; k--)
                        mp[i][k] = mp[i][k - 1];
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值