Description
给出一段英文文章,统计文章中字母出现的频率(即出现的次数)。字母不区分大小写。按照字母的字典顺序进行柱状显示。
Input
第一行为一个正整数,表示有多少组测试数据。每组数据的第一行为一个正整数m (m<100),表示每组测试数据的行数。接下来有m行。每行都是由字母、标点、空格等符号组成的字符串。每行最多1000个字符。
Output
每组数据对应一个柱状显示图输出。上方按照统计频率输出相应高度的“柱”(用星号和点表示,其中星号标识出现频率,点代表空),下方为相应的大写字母。相应参考样例输出。最上方没有多余空行。每组数据结束后有一个空行。
Sample Input
1 2 Given the coordinates of the vertices of a triangle, and a point. You just need to judge whether the point is in the Triangle.
Sample Output
....*..................... ....*..................... ....*..............*...... ....*..............*...... ....*..............*...... ....*..............*...... ....*...*....*.....*...... ....*...*....**....*...... ....*...*....**....*...... *...*..**....**....*...... *...*..**....**..*.*...... *..**.***....**..***...... *..**.***....**..****..... *.********.*.***.*****.... *.********.*.***.******.*. ABCDEFGHIJKLMNOPQRSTUVWXYZ
#include<stdio.h>
#include<string.h>
int main(){
int T,t[26]; //用t数组来记录字母出现的次数
scanf("%d%*c",&T);
for(;T --;){
int n,max = 0; //用max来记录字母出现最多的次数
char ch;
memset(t,0,sizeof t);
scanf("%d%*c",&n);
for(;n --;)
//每组数据只有n行文字
while((ch = getchar()) != '\n'){
//若读入的字符是’\n‘,则代表一行文字已经处理完毕
if(ch <= 'Z' && ch >= 'A')
t[ch-'A']++;
if(ch <= 'z' && ch >= 'a')
t[ch - 'a'] ++;
}
for(n = 0;n < 26;n ++)
if(t[n] > max)
max = t[n];
for(n = max;n > 0;n --){
//输出的柱状显示图的层数就是max的值
for(ch = 0;ch < 26;ch ++)
if(t[ch] - n >= 0)
//只要该字母出现的次数不小于正在输出的这行的层数(最下方的层数为1,往上增加到max层),则应该输出’*‘,否则输出’.‘
putchar('*');
else
putchar('.');
putchar('\n');
}
puts("ABCDEFGHIJKLMNOPQRSTUVWXYZ\n");
}
return 0;
}