UVa 537 Artificial Intelligence?

题目大意:输入一个字符串,根据物理公式P=U*I,已知其中两个量,求第三个量,结果保留两位小数。

Artificial Intelligence?    Artificial Intelligence? 
Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!


So they don't state a problem like ``U=10V, I=5A, P=?" but rather like ``You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There's an electrical current of I=5A through the bulb. Which power is generated in the bulb?".


However, half of the pupils just don't pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: ``Which formulae do I know? Ah yes, P=U*I. Therefore P=10V*5A=500W. Finished."


OK, this doesn't always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)


Today we will check if a computer can pass a high school physics test. We will concentrate on the P-U-I type problems first. That means, problems in which two of power, voltage and current are given and the third is wanted.




Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.


Input 


The first line of the input file will contain the number of test cases.
Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the form I=xA, U=xV or P=xW, where x is a real number.


Directly before the unit (A, V or W) one of the prefixes m (milli), k (kilo) and M (Mega) may also occur. To summarize it: Data fields adhere to the following grammar:


DataField ::= Concept '=' RealNumber [Prefix] Unit
Concept   ::= 'P' | 'U' | 'I'
Prefix    ::= 'm' | 'k' | 'M'
Unit      ::= 'W' | 'V' | 'A'
Additional assertions:


The equal sign (`=') will never occur in an other context than within a data field.
There is no whitespace (tabs,blanks) inside a data field.
Either P and U, P and I, or U and I will be given.
Output 


For each test case, print three lines:
a line saying ``Problem #k" where k is the number of the test case
a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output
a blank line
Sample Input 


3
If the voltage is U=200V and the current is I=4.5A, which power is generated?
A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please.
bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?
Sample Output 


Problem #1
P=900.00W


Problem #2
I=0.45A


Problem #3
U=1250000.00V
我是用结构体来存储数据的,存放单位,数值,物理量,还有'm','k','M'。
程序的关键部分在于字符和double数据在字符串中的读取,也就是通过这道题我了解到了sscanf()函数。用在这道题里面确实很合适,sscanf()函数用法链接: sscanf,sscanf_s及其相关用法
代码如下:
//#define LOCAL
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

char s[300];

struct AI
{
	char Concept, Prefix, Unit;
	double x;
}a[2];

void transform(struct AI &t);
double calculate(char u, struct AI a1, struct AI a2);
char f(char Concept);

int main(void)
{
	#ifdef LOCAL
		freopen("537in.txt", "r", stdin);
	#endif
	int N, kase = 0;
	cin >> N;
	getchar();
	while(N--)
	{
		int i, len;
		++kase; 
		gets(s);
		len = strlen(s);
		for(i = 0; i < len; ++i)//寻找第一个等号
		{
			if(s[i] == '=')
				break;
		}
		sscanf(&s[i] - 1,"%c=%lf%c", &a[0].Concept, &a[0].x, &a[0].Prefix);
		for(++i; i < len; ++i)//寻找第二个等号
		{
			if(s[i] == '=')
				break;
		}
		sscanf(&s[i] - 1,"%c=%lf%c", &a[1].Concept, &a[1].x, &a[1].Prefix);
		transform(a[0]);
		transform(a[1]);

		char u = 'P' + 'U' + 'I' - a[0].Concept - a[1].Concept;//这是要求的物理量
		double res;
		res = calculate(u, a[0], a[1]);

		cout << "Problem #" << kase << endl;
		printf("%c=%.2lf%c\n\n", u, res, f(u));
	}
	return 0;
}
//根据物理量求单位
char f(char Concept)
{
	if(Concept == 'P')
		return 'W';
	if(Concept == 'U')
		return 'V';
	if(Concept == 'I')
		return 'A';
}
//单位换算及转化为国际标准单位 
void transform(struct AI &t)
{
	if(t.Prefix == 'm')
		t.x /= 1000.00;
	if(t.Prefix == 'k')
		t.x *= 1000.00;
	if(t.Prefix == 'M')
		t.x *= 1000000.00;
	t.Unit = f(t.Concept);
}
//根据公式计算
double calculate(char u, struct AI a1, struct AI a2)
{
	if(u == 'P')
		return a1.x * a2.x;
	if(a1.Concept == 'P')
		return a1.x / a2.x;
	return a2.x / a1.x;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值