UVa 10815 Andy's First Dictionary

感觉这道题要比之前几个字符串处理的题目难度要大了一些。


题目大意:给若干行字符串,提取出所有单词并去掉重复的,最后按字典顺序输出。


对于输入大致有两种思路,一种是逐个读入字符,遇到字母的话就放到word里面,直到遇到非字母字符,在word最后放'\0'。

我采用第二种思路,就是用gets()函数逐行读到str字符数组里面,然后逐个把单词提取出来。

Count存放的是Dictionary里单词的个数,每提取一个单词,看看Dictionary里有没有该单词,没有的话放到字典里面,并且计数器加1。

由于功力不够深厚抓狂,最后对Dictionary排序的时候不会写cmp函数,因此用不了qsort(),所以又笨笨的写了个冒泡排序,居然没有超时偷笑


Problem B: Andy's First Dictionary

Time limit: 3 seconds


Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.

Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

Output

Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

Sample Input

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."

So they went home.

Sample Output

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when

国际惯例,AC代码如下:

//#define LOCAL
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

char Dictionary[5005][40];//用来存放单词
int Count = 0;				  //不重复的单词的个数
char str[215], word[40];

int cmp(const void *a, const void *b);

int main(void)
{
	#ifdef LOCAL
		freopen("10815in.txt", "r", stdin);
	#endif

	int i, j;
	while(gets(str))
	{
		int l = strlen(str);
		if(l == 0)
			continue;
		for(i = 0; i < l; ++i)
			str[i] = tolower(str[i]);
		i = 0;

		while(i < l)
		{
			if((i == 0 || str[i - 1] < 'a' || str[i - 1] > 'z')//判断一个单词的开始
				&& str[i] >= 'a' && str[i] <= 'z')
				word[0] = str[i];
			else
			{
				++i;
				continue;
			}

			++i;
			int j = 1;
			while(str[i] >= 'a' && str[i] <= 'z' && i < l)
			{
				word[j++] = str[i++];
			}
			word[j] = '\0';

			for(j = 0; j < Count; ++j)
			{
				if(!strcmp(Dictionary[j], word))
					break;
			}
			if(j == Count)
				strcpy(Dictionary[Count++], word);
			}
	}
	
	for(i = Count - 1; i > 1; --i)//不会用qsort,只能恶心地写个冒泡了
	{
		for(j = 0; j < i; ++ j)
		{
			if(strcmp(Dictionary[j], Dictionary[j + 1]) > 0)
			{
				char t[30];
				strcpy(t, Dictionary[j]);
				strcpy(Dictionary[j], Dictionary[j + 1]);
				strcpy(Dictionary[j + 1], t); 
			}
		}
	}
	for(i = 0; i < Count; ++i)
		cout << Dictionary[i] << endl;
	return 0;
}

最后去网上查了一下别人写的cmp函数,试了一下同样AC!

int cmp(const void *a, const void *b)
{
    return strcmp((char *)a, (char *)b);
}
qsort(Dictionary, Count, sizeof(Dictionary[0]), cmp);



Joke and image taken from the Web

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值