zoj-2724 Windows Message Queue(二叉堆&&优先队列)

Windows Message Queue
Time Limit:2000MS     Memory Limit:65536KB 
Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.


Input
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.


Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.


Sample Input
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET
Sample Output
EMPTY QUEUE!
msg2 10
msg1 10

EMPTY QUEUE!

//二叉堆,小根堆
//通过一维数组模拟实现
//Memory 1812 KB    Time 50 ms	
#include<stdio.h>
struct info
{
	char mes[10];
	int time,pir,date;
}f[60002];
int heap[60002];
bool compare(int a,int b)
{
	if(f[a].pir<f[b].pir) return false;
	if(f[a].pir>f[b].pir) return true;
	if(f[a].time<f[b].time) return false;
	return true;
}
int main()
{
	int i,t,k,sum=0,time=0;
	char s[10];
	while(scanf("%s",s)!=EOF)
	{
		if(s[0]=='G'){
			if(!sum) printf("EMPTY QUEUE!\n");
			else{
				printf("%s %d\n",f[heap[1]].mes,f[heap[1]].date);//输出根
				k=1;
				heap[1]=heap[sum--];//将队尾元素放到队首
				while(2*k<=sum){//与子节点中权值小的交换
					t=2*k;
					if(t<sum&&compare(heap[t],heap[t+1])) t++;//左右节点权值最小的
					if(compare(heap[k],heap[t])){
						i=heap[t];heap[t]=heap[k];
						heap[k]=i;k=t;
					}
					else break;
				}
			}
		}
		else{
			scanf("%s%d%d",f[time].mes,&f[time].date,&f[time].pir);
			f[time].time=time;
			heap[++sum]=time++;//记录位置
			k=sum;
			while(k>1){//权值小,向上冒泡
				t=k/2;
				if(compare(heap[t],heap[k])){
					i=heap[t];heap[t]=heap[k];
					heap[k]=i;k=t;
				}
				else break;
			}
		}
	}
	return 0;
}

//优先队列
//Memory 1240 KB   Time 40 ms	
#include<iostream>
#include<stdio.h>
#include<queue>
using namespace std;
struct node
{
	int mes,pri;
	char c[10];
	friend bool operator < (const node &a,const node &b)
	{
		return a.pri>b.pri;
	}
};
int main()
{
	priority_queue<node> que;
	node a;
	char s[10];
	while(scanf("%s",s)!=EOF)
	{
		if(s[0]=='G'){
			if(que.empty()) printf("EMPTY QUEUE!\n");
			else{
				a=que.top();
				que.pop();
				printf("%s %d\n",a.c,a.mes);
			}
		}
		else{
			scanf("%s%d%d",a.c,&a.mes,&a.pri);
			que.push(a);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值