poj-1988-Cube Stacking (并查集)

Cube Stacking
Time Limit:2000MS     Memory Limit:30000KB
Description
Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 


Write a program that can verify the results of the game. 
Input
* Line 1: A single integer, P 


* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.


Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 
Output
Print the output from each of the count operations in the same order as the input file. 
Sample Input
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4
Sample Output
1
0

2

//M:将x所在栈放到y所在栈的栈顶
//C:输出x到栈底的立方体个数
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int top[100003],bot[100003],ans[100003];
//top[x]为x栈顶元素,bot[x]为x到栈底元素,ans[x]为x到栈底的立方体数
int find(int x)
{
	if(bot[x]==x) return x;
	int s=bot[x];
	bot[x]=find(bot[x]);//路径压缩
	ans[x]+=ans[s];//同时计算到栈底的立方体个数
	return bot[x];//返回栈底
}
void join(int x,int y)
{
	x=find(x);y=find(y);
	bot[x]=y;
	find(top[y]);
	ans[x]=ans[top[y]]+1;
	top[y]=top[x];
}
int main()
{
	int i,n,x,y;
	char c[4];
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{
		top[i]=i;
		bot[i]=i;
		ans[i]=0;
	}
	for(i=1;i<=n;i++)
	{
		scanf("%s",c);
		if(c[0]=='C') {
			scanf("%d",&x);
			find(x);
			printf("%d\n",ans[x]);
		}
		else{
			scanf("%d %d",&x,&y);
			join(x,y);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值