poj-2421 Constructing Roads(最小生成树 Kruskal算法)

Constructing Roads
Time Limit:2000MS     Memory Limit:65536KB    
Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 


We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 


Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
Sample Output

179

题意:n个村庄,及村庄之间的距离,q条路已连通村庄,问连通所有村庄的最短路径。

Kruskal算法的思想:

按照边权值递增的顺序排序边集e;

建立由n棵树组成的森林,每棵树包含图的一个节点;

最小生成树的权和sum=0;

for(k=1;k<=m;k++)  //枚举e中的所有边

{ if (第k条边(i ,j)的两个短点分属于两颗子树)

{ i节点所在子树并入j节点所在子树;

sum+=(i ,j)的边长 }

}

输出sum;

把每棵树看成一个集合,变成了典型的并查集运算。

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
struct node
{
	int i,j;
	int distant;
}f[10000];
int s[101];
int find(int x)
{
	return s[x]==x?x:s[x]=find(s[x]);
}
bool cmp(const node &a,const node &b)
{
	return a.distant<b.distant;
}
int main()
{
	int i,j,q,n,dis;
	int a,b,sum=0,m=-1;
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=n;j++)
		{
			scanf("%d",&dis);
			if(i==j) continue;
			f[++m].i=i;
			f[m].j=j;
			f[m].distant=dis;
		}
		s[i]=i;
	}
	scanf("%d",&q);
	for(i=1;i<=q;i++)
	{
		scanf("%d%d",&a,&b);
		s[find(a)]=find(b);
	}
	sort(f,f+m+1,cmp);
	for(i=0;i<=m;i++)
	{
		if(find(f[i].i)!=find(f[i].j))
		{
			sum+=f[i].distant;
			s[find(f[i].i)]=find(f[i].j);
		}
	}
	printf("%d\n",sum);
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值