HDU 题目1051 Wooden Sticks

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11126    Accepted Submission(s): 4579


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3
 

此题意思即使按照题意,一开始题意没搞清楚,理解为小的木棍不用时间,实际上是在原来安装那的木棍上安装不用花时间。。。



#include <stdio.h>
struct stick
{
    int len;
    int weight;
    int cnt;
}woolen[5005],t;
int main(void)
{
  // freopen("F.txt","r",stdin);
    int i,j,n,m,k,sum,count;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&m);
            for(j=1;j<=m;j++)
            {
                scanf("%d%d",&woolen[j].len,&woolen[j].weight);
                woolen[j].cnt=0;
            }

          //  for(j=1;j<=m;j++)
            //  printf("%d %d\n",woolen[j].len,woolen[j].weight);
            for(j=1;j<=m;j++)
            {
                for(k=1;k<=m-j;k++)
                {
                    if(woolen[k].len>woolen[k+1].len)
                    {
                        t=woolen[k];
                        woolen[k]=woolen[k+1];
                        woolen[k+1]=t;
                    }
                    if(woolen[k].len==woolen[k+1].len&&woolen[k].weight>woolen[k+1].weight)
                    {
                         t=woolen[k];
                        woolen[k]=woolen[k+1];
                        woolen[k+1]=t;
                    }
                }
            }
         //  for(j=1;j<=m;j++)
             // printf("%d %d\n",woolen[j].len,woolen[j].weight);
          /*  for(j=1;j<=m;j++)
            {
                if(woolen[j].cnt==0)
                {
                   for(k=1;k<j;k++)
                {
                    if(woolen[j].weight>=woolen[k].weight)
                       {
                            woolen[j].cnt=1;
                            break;
                       }
                }
                }


            }*/
            for(j=1;j<=m;j++)
            {
                if(woolen[j].cnt==0)
                {
                    t=woolen[j];

                }
                for(k=j+1;k<=m;k++)
                {
                    if(woolen[k].cnt==0)
                    {
                        if(t.weight<=woolen[k].weight)
                        {
                            t=woolen[k];
                            woolen[k].cnt=1;
                        }
                    }
                }
            }

            sum=0;
            for(j=1;j<=m;j++)
                {
                    if(woolen[j].cnt==0)
                sum++;
                }
                printf("%d\n",sum);
        }
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值