POJ 2376 Cleaning Shifts

Cleaning Shifts
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12883 Accepted: 3333

Description
Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input
* Line 1: Two space-separated integers: N and T

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output
* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.


让每一分钟都育牛在打扫卫生,最重要的一点就是right的取值,第一头牛的时间段是start—last,那么下一头牛就在last+1的时间段开始。

另外,一直WA的原因是,条件和赋值都用的一个变量,没有用中间变量来代替,很容易造成死循环,死机,这样一来,WA的情况还是很幸运的啊。。。。。


#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;

struct node
{
    int start;
    int last;
}a[25500];

bool cmp(struct node p,struct node q)
{
    if(p.start!=q.start)
        return p.start<q.start;
    else
        return p.last<q.last;
}

int main(void)
{
   // freopen("D.txt","r",stdin);
    int n,t;
    scanf("%d%d",&n,&t);
    int minx=99999999;
    int maxn=-1;
    for(int i=1;i<=n;i++)
       {
            scanf("%d%d",&a[i].start,&a[i].last);
            minx=min(minx,a[i].start);
            maxn=max(maxn,a[i].last);
       }
       if(minx>1||maxn<t)
        printf("-1\n");
       else
       {
           sort(a+1,a+n+1,cmp);
           int right;
           int l;
           for(int i=1;i<=n;i++)
           {
               if(a[i].start!=1) break;
               else
              {
                  l=i;
                    right=a[i].last+1;
              }
           }
           int flag=1;
           int k=1;
           int sum=1;
           while(1)
           {
               if(right>t) break;
               int ok=0;
               int i;
               l=k;
               int endx=right-1;
             for( i=l+1;i<=n;i++)
               {
                   if(right>=a[i].start&&right<=a[i].last)
                   {
                       ok=1;
                       endx=max(endx,a[i].last);
                       k=i;
                   }

               }
               if(ok)
               {
                   sum++;
                   right=endx+1;
               }
               else
               {
                   flag=0;
                   break;
               }
           }
           if(flag==0) printf("-1\n");
           else printf("%d\n",sum);
       }


    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值