PKU 3252 Round Numbers

Round Numbers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9477 Accepted: 3396

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively  Start and  Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range  Start.. Finish

Sample Input

2 12

Sample Output

6

给一个十进制的数,将这个十进制的数化成二进制后,如果0的个数大于等于1的个数,那么就叫Round Numbers,输入一个区间,输出这个区间内有多少个这样的数。

计算排列组合的时候,一个是可以直接计算的,另一个是打表,向这题需要很多次计算组合排列的地方,就用打表更好。

先打表,将排列组合计算出来,用一个二维数组即可。

再将十进制转化为二进制,存到一个数组里边,bin[0]保存这个二进制的长度




代码是借鉴这位同学的

ζёСяêτ - 小優YoU


#include<iostream>
using namespace std;
int c[33][33]={0};
int bin[35];  //十进制n的二进制数
/*打表,计算nCm*/
void play_table(void)
{
 for(int i=0;i<=32;i++)
  for(int j=0;j<=i;j++)
   if(!j || i==j)
    c[i][j]=1;
   else
    c[i][j]=c[i-1][j-1]+c[i-1][j];
// c[0][0]=0;
 return;
}
/*十进制n转换二进制,逆序存放到bin[]*/
void dec_to_bin(int n)
{
 bin[0]=0;   //b[0]是二进制数的长度
 while(n)
 {
  bin[++bin[0]]=n%2;
  n/=2;
 }
 return;
}
/*计算比十进制数n小的所有RN数*/
int round(int n)
{
 int i,j;
 int sum=0;  //比十进制数n小的所有RN数
 dec_to_bin(n);
 /*计算长度小于bin[0]的所有二进制数中RN的个数*/
 for(i=1;i<bin[0]-1;i++)
  for(j=i/2+1;j<=i;j++)
   sum+=c[i][j];
 /*计算长度等于bin[0]的所有二进制数中RN的个数*/
 int zero=0;  //从高位向低位搜索过程中出现0的位的个数
 for(i=bin[0]-1;i>=1;i--)
  if(bin[i])   //当前位为1
   for(j=(bin[0]+1)/2-(zero+1);j<=i-1;j++)
    sum+=c[i-1][j];
  else
   zero++;
 return sum;
}
int main(void)
{
 play_table();
 int a,b;
 cin>>a>>b;
 cout<<round(b+1)-round(a)<<endl;
 return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值