HDU 1002 A + B Problem II

A + B Problem II

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 12   Accepted Submission(s) : 2
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110

大数相加,输入的字符串,最高位在0位置下标处,转化成整形数组的时候要把个位放在0位置下标处,相加的时候不容易出错。下一个坑人的地方是输出。。i==n的时候,只输出回车。 在给定的案例之间才有一行空格。

#include <iostream>
#include <stdio.h>
#include <memory.h>
#include <string>
#include <fstream>
using namespace std;
char s1[1005],s2[1005];
int s3[1005],s4[1005],s[1005];
int main(void)
{

// freopen("B.txt","r",stdin);
   int t;
   while(cin>>t)
   {
       for(int i=1;i<=t;i++)
       {
           memset(s3,0,sizeof(s3));
           memset(s4,0,sizeof(s4));
           memset(s,0,sizeof(s));
          // printf("Case %d:\n",i);
            cin>>s1>>s2;
            cout<<"Case "<<i<<":"<<endl;
         //  scanf("%s %s",s1,s2);
         //  printf("%s + %s = ",s1,s2);
          cout<<s1<<" + "<<s2<<" = ";
           int l1=strlen(s1);
           int k=0;
           for(int j=l1-1;j>=0;j--)
            s3[k++]=s1[j]-'0';
           int l2=strlen(s2);
           k=0;
           for(int j=l2-1;j>=0;j--)
            s4[k++]=s2[j]-'0';
           int l=(l1>l2)?l1:l2;
           int jin=0;
         //  int k=0;
           for(int j=0;j<l;j++)
           {
               s[j]=s3[j]+s4[j]+jin;
               jin=s[j]/10;
               s[j]=s[j]%10;
              // cout<<s[k];
             //  k++;
           }
           int j;
           for(j=1005;j>=0;j--)
           {
               if(s[j])
               {
                   break;
               }
           }
          // cout<<s;
           for(k=j;k>=0;k--)
           // printf("%d",s[k]);
           cout<<s[k];
        //  printf("\n");
         cout<<endl;
         if(i!=t)
          //  printf("\n");
            cout<<endl;
       }
   }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值